My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 122306: Mouse wheel sometimes doesn't scroll over transformed parts of webpage
8 people starred this issue and may be notified of changes. Back to list
 
Project Member Reported by danakj@chromium.org, Apr 5, 2012
Version: WebKit 113341
OS: Linux desktop

What steps will reproduce the problem?
1. Open http://acko.net/blog/this-is-your-brain-on-css/
2. Put mouse over a paragraph of text in the blog post.
3. Scroll the mouse wheel.

What is the expected output? What do you see instead?
The page should scroll. Instead the mouse wheel does nothing and the page does not scroll.

Scrolling on other parts of the page works. And once the page is scrolled down sufficiently, then scrolling on this text works also. I assume this is once the transforms are all flat.
Apr 5, 2012
#1 danakj@chromium.org
Oh and FYI I am running without threaded compositor.
Apr 5, 2012
#2 danakj@chromium.org
(No comment was entered for this change.)
Summary: Mouse wheel does not scroll over transformed parts of webpage
Apr 6, 2012
#3 saintlou@chromium.org
FWIW the mouse wheel does not work either with this page in my experiments on Mac and Linux. Not a blocker: removing ReleaseBlock-Stable
Status: Available
Labels: -mstone-19 -ReleaseBlock-Stable Mstone-20
Apr 6, 2012
#4 rjkroege@chromium.org
I'll look at it if no one else wants it.
Owner: rjkroege@chromium.org
Apr 15, 2012
#5 anico...@chromium.org
(No comment was entered for this change.)
Labels: -Feature-Fletcher Hotlist-Link
Apr 18, 2012
#6 rby...@chromium.org
(No comment was entered for this change.)
Labels: Team-FletcherWebVents
Apr 18, 2012
#7 rjkroege@chromium.org
wjmaclean@ you / nat fixed this right?
Cc: nd...@chromium.org
Apr 23, 2012
#8 wjmacl...@chromium.org
I didn't do anything specific to this bug myself, although it may have been fixed as a by-product of other efforts. I'm assuming it doesn't still reproduce?

Apr 24, 2012
#9 danakj@chromium.org
Seems to be working :)
Status: Verified
Apr 25, 2012
#10 steven.w...@gmail.com
I can no longer reproduce the bug with 20.0.1116.0 (133876).
Apr 25, 2012
#11 steven.w...@gmail.com
Argh, apologies. Figures that after 5 minutes of frantic scrolling and not encountering the bug, it would pop up a minute later.

It's really random and hard to trigger. But it happens pretty much instantly on load when it does, and then it's very obvious. All I can recommend is refreshing a lot and closing / reopening the browser to reproduce.

Apr 25, 2012
#12 rjkroege@chromium.org
steven@ Can you give me more info on how to replicate?
Apr 25, 2012
#13 danakj@chromium.org
Reopening then, I also can repro it if I try a bit!

Rob:
1. Visit acko.net.
2. Position mouse over the latest posts which are rotated on screen at page load. Now don't move the mouse anymore.
3. Hit ^R to refresh.
4. Roll scroll wheel down as page is loading.
5. See the page not scroll when it's done loading.
6. Repeat from 3 until it repros. (It's quite consistent for me.)

This is without threaded compositor.
Status: Assigned
May 8, 2012
#14 dhar...@google.com
M20 has sailed. If this need to be part of M20, put them back with appropriate release blocker label.
Labels: -Mstone-20 MovedFrom-20 Mstone-21
May 11, 2012
#15 rby...@chromium.org
I'm really struggling to reproduce this.  We don't have evidence of this being a problem elsewhere, do we?  Moving to M22.
Summary: Mouse wheel sometimes doesn't scroll over transformed parts of webpage
Status: Available
Owner: ---
Labels: -Hotlist-Link -Mstone-21 Mstone-22
May 11, 2012
#16 rby...@chromium.org
Dana showed me how to repro this - scrolling quickly while the page is loading seems to break scrolling, it won't work again until you reload the page.  I can now reproduce reliably.

Definitely a problem, but probably not super-urgent.  Returning to M21 available.
Labels: -Mstone-22 Mstone-21
Jun 14, 2012
#17 wiltz...@chromium.org
who's going to own this one? does it need an owner (obviously not making m21)?
Jun 14, 2012
#18 danakj@chromium.org
Ya, not for 21 I guess.
Owner: rjkroege@chromium.org
Cc: rby...@chromium.org
Labels: -Mstone-21 Mstone-22
Aug 21, 2012
#19 rjkroege@chromium.org
(No comment was entered for this change.)
Labels: -Mstone-22 Mstone-23
Sep 12, 2012
#20 rjkroege@chromium.org
(No comment was entered for this change.)
Status: Started
Sep 18, 2012
#21 rjkroege@chromium.org
(No comment was entered for this change.)
Labels: -Mstone-23 Mstone-24
Oct 18, 2012
#22 rjkroege@chromium.org
(No comment was entered for this change.)
Status: Available
Oct 30, 2012
#23 rjkroege@chromium.org
(No comment was entered for this change.)
Labels: -Mstone-24 Mstone-25
Nov 20, 2012
#24 kar...@google.com
Bugs that have been moved 5 or more times. Removing Mstone label.
Labels: -Mstone-25 MstoneRemoved
Jan 14, 2013
#25 rjkroege@chromium.org
(No comment was entered for this change.)
Owner: rby...@chromium.org
Jan 24, 2013
#26 rby...@chromium.org
I'm not able to repro this now, maybe it's fixed, or maybe it's a strange edge case that's very hard to trigger.  Either way we haven't heard of similar problems elsewhere, seems unlikely we'll ever make this a priority.
Status: WontFix
Mar 10, 2013
#27 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Area-WebKit -Feature-GPU-Compositing Cr-Internals-GPU-Compositing Cr-Content
Apr 5, 2013
#28 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Cr-Internals-GPU-Compositing Cr-Internals-Compositing
Apr 5, 2013
#29 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Cr-Content Cr-Blink
Sign in to add a comment

Powered by Google Project Hosting