My favorites | Sign in
Project Home Wiki Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 312: Blutrol: Support for iPega 017
11 people starred this issue and may be notified of changes. Back to list
Status:  Fixed
Owner:  ----
Closed:  Jun 2013


Sign in to add a comment
 
Reported by georgesh...@gmail.com, Feb 7, 2013
What steps will reproduce the problem?
1. Connecting to any mode of the iPega controller using btstack

What is the expected output? What do you see instead?
It would be great if no pairing code was required as I cannot currntly use this device fully using Apple iCade or at all using Blutrol. 

What version of the product are you using? On what operating system?
iOS 6.1 running the latest blutrol/btstack as of this moment. 

Log coming....
Feb 12, 2013
Project Member #1 matthias.ringwald@gmail.com
hi.. how is this device supposed to work with iOS? It should be possible to pair using iOS Bluetooth settings and then just select iOS iCade in Blutrol?


Feb 12, 2013
#2 georgesh...@gmail.com
It does have iCade mode, but unfortunately iCade doesn't make use of the start/select or the L/R buttons.  I would ideally like to map out to games like swordigo, or n64 emulators. 

Sent from my iPad
Feb 21, 2013
#3 shoeb...@gmail.com
So I have the ipega controller, I've been trying to get it to work with the snes9x EX emulator on my phone, but it won't connect. I know some emulators won't connect with certain controllers, but even when I try to set it to icade mode, it won't connect. Does anyone else have this problem with this controller on an iOS emulator?
Feb 21, 2013
#4 georgesh...@gmail.com
BTStack doesn't work with iCade mode in this controller.  If you stick to the regular iOS Bluetooth stack it'll work.   I've been playing SNES9X with mine, so it should work until BTStack, someday hopefully, accounts for this controller.  
Feb 21, 2013
Project Member #5 matthias.ringwald@gmail.com
HI. I've written an email to Pega to ask for a free controller. I've also removed the "BTstack iCade" mode in the latest Blutrol version. 

I'm not responsible for other people's products, e.g. the SNES9X EX emulator, please contact it's developer directly.
Feb 21, 2013
#6 georgesh...@gmail.com
In this case the issues isn't SNES9X, its a completely arbitrary fact.  I hope you can get a hold of the iPega controller.  Its normally sold out on all the sites that sell it for its extremely low price.  I got mine from DX.com for $27 after  tax.
Feb 21, 2013
#7 shoeb...@gmail.com
So, I turn the controller on, set it to icade mode with my ios blue tooth and when I go into the emulator, I'm still unable to play the game! Am I doing something wrong? Sorry you're the first person I've talked with that has been able to make it work on the same emulator haha

Feb 21, 2013
#8 shoeb...@gmail.com
After reading more thoroughly it looks like I'll need to download blutrol. Didn't see that haha I'll have to download it today.
Feb 21, 2013
#9 georgesh...@gmail.com
Sorry for cluttering up the bug report matthias :S

Shoeb, I can't walk you through it, unfortunately, as I go by feel.  I do know that you have to turn on iCade mode within SNES9X and configure it within its sub menus.  One warning though, not all the buttons work in iCade mode.  If that doesn't help you'll need to do as matthias suggest and talk to the developer as this is a posting requesting iPega compatibility within blutrol.
Feb 21, 2013
#10 shoeb...@gmail.com
No worries, thanks for your help!
Feb 21, 2013
Project Member #11 matthias.ringwald@gmail.com
Uhm, I'm the developer of Blutrol, but not of any emulator. 

Pega isn't supported by Blutrol at the moment, although that may change. If you can put that thing into an iCade mode, you can use Blutrol to map it's buttons to touches on the screen, that should also work with an emulator. There, it might be easier/better to add support for iCade directly.
Feb 21, 2013
#12 georgesh...@gmail.com
Does that mean you can use Blutrol for screen mappings with native iCade mode?
Feb 21, 2013
Project Member #13 matthias.ringwald@gmail.com
@georgeshort: yes, that's the basic idea of Blutrol. Some links:
 * product page: http://www.ringwald.ch/cydia/blutrol/
 * a review: http://www.icontrolpad.com/blutrol
Feb 21, 2013
#14 georgesh...@gmail.com
I hadn't realized.  Thank you.

I'd thought it only mapped BTStack.
Mar 15, 2013
#15 georgesh...@gmail.com
Matthias, have you had any luck with arranging a sample ipega?  And if they said 'no', would you accept the loan of my own?  Is it a difficult task to add a new controller into your API, or is it just a matter of registering the appropriate 'keystroke' from the device?
Apr 1, 2013
Project Member #16 matthias.ringwald@gmail.com
not really, but I have ordered one from DX and just got the "it's shipped" mail.
Apr 1, 2013
#17 georgesh...@gmail.com
BTW, thank you for the work you've been putting it.  The v3 update really made the PhoneJoy a delightful product to use.  The anaolog controls are still a little iffy, but things are shaping up beautifully.
Apr 27, 2013
#18 antonioj...@gmail.com
Thanks for you great work, what do you tell us about the iPega? Analogs working?
Apr 27, 2013
#19 georgesh...@gmail.com
The iPega only works in iCade mode right now.  So Analog does not work, though the left thumb works as a d-pad.  Likewise not all the buttons works.

Without Blutrol some of the buttons are even mapped to do the same thing, which makes it unusable.  With matthias' hard work though, its usable for games that don't have many buttons.
Apr 27, 2013
#20 matthias@bluekitchen-gmbh.com
HI Guys. I've received my iPega last week, but didn't had a closer look yet. I think the analog controls require too much force to play with. 

The iPega has 4 modes: iCade, Keyboard, Mouse, Joystick. With iCade, Blutrol certainly misses a few buttons and the analog nubs won't work. The Mouse mode works with BTC Mouse, but it's rather hard to control anything. So, for the analog nubs to work, I guess the Joystick mode will be used. I'll see what data it sends. So, I think Blutrol will a) add the extra buttons in iCade and b) support the Joystick mode if possible.
Apr 27, 2013
#21 georgesh...@gmail.com
Glad to hear it!  Thanks Matthias!  I prefer my PhoneJoy by far, but the iPega is definitely A)Convenient to carry (size + holster) and B)Affordable.
Apr 27, 2013
Project Member #22 matthias.ringwald@gmail.com
Ok, I've looked at the data from the Joystick mode. Surprisingly, well, I was at least surprised, is that it provides an HID Joystick. Think of a real physical joystick. Anyway, that's fine for Blutrol :)
Apr 27, 2013
#23 georgesh...@gmail.com
You make it sound like its a quick case of recording 'keystrokes' in that kind of case. Would It technically be possible to set BluTrol to associate any Bluetooth button push to a physical screen.  Like... 

Press a button.  Good, now place it on the screen. 

Also, would it be possible for a button push to light up the onscreen button during configuration? In the case of iCade devices the button placement doesn't necessarily correspond to the onscreen labeling. 

You do amazing things Matthias! 
Apr 27, 2013
#24 antonioj...@gmail.com
That's great!
Have fun Playing and coding!!
Apr 30, 2013
#25 ameeronl...@hotmail.com
Hello all,
Any update about ipega ?
I get new one and i cant connect it with my iphone
Can any one help me if it work or not ?
And how i can make it work ?

Pleaseeeeeeeeee
Apr 30, 2013
#26 georgesh...@gmail.com
This is not an iPega forum ameeronl, but here's a quick tip.  You'll have to look elsewhere for further help.

Hold the Home button plus the Y button to get into scanning mode (blinking LED).  Use the Bluetooth connection settings in the Settings app to connect.  From there you can use Blutrol to further customize.

Good luck.
May 1, 2013
#27 ameeronl...@hotmail.com
to #26 i know that not a form but i ask here because i search over the net and did not found any answers ! i know about holding HOME and Clicking Y and connected to the iphone but when i start some game like street fighter 4 or Most wanted the joystick not work ! even angry birds not work and langue of evil ! non of these game did work and I try to use blutrol but not work ! i found on the internet Blutrol is not work with iphone yet ... so please tell me do you connect with blutrol or without ? and please tell me one game name that work 100% to know what is the problem ... or what should i do ????
May 1, 2013
#28 georgesh...@gmail.com
BluTrol does work on the iPhone.  I use it with my iPega.  It sounds like you just aren't configuring BluTrol for the games to be played.  Also, Blutrol isn't a magical application that allows you to play ANY game with a gamepad - it allows you to use physical gamepad buttons to touch onscreen buttons.  So start with a game that has buttons onscreen (not angry birds).

See if these instructions help at all:
http://www.ringwald.ch/cydia/blutrol/
http://appadvice.com/appnn/2013/03/cydia-tweak-how-to-connect-a-playstation-controller-to-an-ios-device-with-blutrol-3-0
http://www.phonejoy.us/support/getting-started/ios/blutrol-setup-guide/
http://www.icontrolpad.com/blutrol/

If these instructions don't help you'll have to reach out to matthias or something...  this thread is NOT about configuring BluTrol so please stop requesting help with that here.
May 1, 2013
#30 ameeronl...@hotmail.com
i dont know what wrong with you man ! i know what is blutrol and i know how it work and how take a screenshot and how match the buttons !!!! and differently i know its not a MAGICAL APPLICATION !

what I say IS i have IPhone connected with Ipega BUT its not work with blutrol or without blutrol !!

and this is the control list that support by blutrol
http://www.ringwald.ch/cydia/blutrol/
Supported Game Controllers

    Bluetooth Keyboard (Supported keys: W, A, D, S, U, I, O, H, J, K, B, N, M and space)
    DuoGamer
    iCade
    iControlPad
    iMpulse (shoulder buttons are NOT supported)
    PhoneJoy
    PS3 Sixpair/Dualshock 3
    Wii Remote (aka Wiimote)
    Zeemote JS1 (Analog stick acts as D-Pad)

so how its connect with you if the application Blutrol not support ipega ??
May 1, 2013
#32 georgesh...@gmail.com
iPega is an iCade controller.  

By pressing Home+Y you are connecting via iCade mode (as per the instructions that came with the iPega) to your iPhone. 

Configure Blutrol as an iCade controller.

Currently only SOME of the buttons for the iPega work with the iPhone.  The same buttons work with or without Blutrol, but Blutrol gives you a lot more control over what the buttons do exactly.  

As a troubleshooting steps, try dragging all of the Blutrol buttons to only one button in League of Evil (like jump).  See if any of the buttons at all make your character jump.
May 1, 2013
#33 hoodiemu...@gmail.com
Hey Matthias..

I'm so glad you have looked in to the iPega. I can't wait till that next update is there with support for this controller. I think most of us won't pay the dollars for the iControlpad since it's so expensive yet I don't like the design either. The iPega is great and I can't wait till I can use all the buttons with BluTrol.

I'm very happy that you guys support this (cheap) controller!

Thanks a lot!
May 14, 2013
#34 hoodiemu...@gmail.com
any news?
May 14, 2013
#35 georgesh...@gmail.com
If there was you would have received an update in Cydia by now :)

Patience. ;)
May 14, 2013
#36 gsain...@gmail.com
any updates concerning blutrol and ipega???

May 14, 2013
Project Member #37 matthias.ringwald@gmail.com
as requested, a short update.

the iPega doesn't like to pair with a regular PIN code when using BTstack. It does pair with iOS using Secure Simple Pairing though. The result of this is: a) I will update Bluetooth Companion to receive data from the iPega. b) it will take a bit longer to do so then to add iPega support only in Blutrol, c) this will ultimatively be better as iOS does allow for connecting from the iPega to the iOS device whereas that's not possible with the current BTstack architecture. We're getting ther...

We'll release an update to Blutrol today/tomorrow that will fix the lag with some games and analog controls (that's really bad if that happens), then I'll be back on adding support for iPega and Wii U Pro.
Summary: Blutrol: Support for iPega 017 (was: blutrol/btstack and the iPega 017 - random pairing code required)
Status: Started
May 16, 2013
#38 ingwie2...@googlemail.com
I have the iPega myself.

Pairing it in Joystick Mode with the iPhone outright makes it act SUPER odd! Like switching between pages stops and you can litterally swipe it for a moment, let it go, and it'll stay there.

In the keyboard mode, I don't see the needed buttons to use this pad with. Uh, well I can't even pair it up.

The pair-code issue is really annoying. Because I have to use it in the limited iCade mode, but being unable to use the actual start and select buttons totally hurts.

Has there been any development? I have this device sitting right here.

Regards, Ingwie.
May 17, 2013
#39 nicocor...@gmail.com
Same thing happens to me in joystick mode, the springboard starts to lock up amd act weird
The best we can use for now is the ipega in icade mode.
In my case, I don't care much about the start and select buttons, but there is an issue when playing games without a fixed on-screen joystick. The way bluetrol fixes that is by sending a first tap, so that the joystick is displayed and them move in the direction you want. But I found out that it only happens for left and down directions. I have already reported this to the devs and provided a video to them so they can fix it.
Being able to use the start and select buttons would also be appreciated, but is not a show stopper for me at least

Regards
May 24, 2013
#40 aaron1he...@gmail.com
Status on iPega update please,
May 29, 2013
#41 gsain...@gmail.com
i hope to see it come out soon....t having the ipega with idevices is pretty useless without a real blutrol for it!is there any updates on the blutrol version including ipega? is it going to use the analog sticks?
May 30, 2013
#42 matthias@bluekitchen-gmbh.com
Yeah, pairing in Joystick mode (it sends 50-100 updates per second) somehow overloads the iOS HID driver. I first thought that this was a bug on my side.... took me a while to just try without my code.

Not forwarding the events from the iPega to the iOS HID driver helps with this issue a lot.

So, I have a working version (All buttons but HOME button (it doesn't send events), analog controls work). It didn't work for Roger, so a bit more testing/debugging is necessary... soon...


May 30, 2013
#43 gsain...@gmail.com
niiiiiice.thank you guys for being geniuses.
May 31, 2013
#44 gsain...@gmail.com
....when???  
Jun 4, 2013
#45 aaron1he...@gmail.com
Is it gonna be before june ends?or after?,
Jun 5, 2013
Project Member #46 matthias.ringwald@gmail.com
we'll shoot for this month :)
Jun 5, 2013
#47 amir.sa...@gmail.com
Good news :) will be very very long month ever !!
Jun 11, 2013
#48 Jamy66...@gmail.com
Hello I'm having an issue with finding information with the key associations. I may just have been looking in the wrong places but its getting frustrating now. I want to use my ipega Bluetooth controller to play my playstation games (via psx4all) on my iPhone 5. Simple enough you might think, connect controller via iOS Bluetooth. Use blutrol to map keys and put controller into icade mode. But no where is the information that I can find that tells you what buttons of the controller are linked to the virtual icade buttons. If I knew that It would just mean dragging the right icade virtual button over the on-screen virtual playstation button. 
Jun 13, 2013
#50 cartma...@gmail.com
Hello! 
To help me and some friends that bought the same controller in mapping it on iCade mode, I found this by trying on games (long test!):
Y=6
B=5
A=7
X=8
L=9
R=0

Hope it helps!
Jun 14, 2013
#51 gsain...@gmail.com
when is this blutrol update coming out??? its long...
Jun 14, 2013
#52 aaron1he...@gmail.com
Yes!we need weekly update :|
Jun 14, 2013
#54 ameeronl...@hotmail.com
Please please support the analog pleaseeeeeee ... 

Sent from iphone
Jun 14, 2013
#55 gsain...@gmail.com
my ipega is just sittin there and its useless without blutrol.....when are they going to upload it to cydia..
.
Jun 14, 2013
#56 aaron1he...@gmail.com
After ipega compablity im willing to buy full price and donate some extra if update comes soon :(:)
Jun 14, 2013
#57 georgesh...@gmail.com
Matthias, since I reported the 'bug', can I request it be closed?  The vast majority of posts are people begging vs providing productive information. 

Again, many thanks for the work you do.  I look forward to the fruits of your labour, whenever that may be.
Jun 15, 2013
#58 gsain...@gmail.com
...
Jun 15, 2013
#59 gsain...@gmail.com
its coming soon.....still anticipating

Jun 17, 2013
#60 matthias@bluekitchen-gmbh.com
@georgesh.. don't worry.

It looks like we'll meet the end of June 'deadline', in fact, it might even be ready end of this week (but that requires some work of Roger, so I'm curious too)
Jun 20, 2013
#61 sgill1036
Additional generic "when is it coming out" comment...
Jun 20, 2013
#62 gsain...@gmail.com
man i should learn programming for the next year so that i can create tweaks for myself....waiting and paying doesnt cut it anymore.
Jun 20, 2013
#63 gsain...@gmail.com
its taking long....
Jun 20, 2013
#65 sgill1036
I know this the wrong section to be asking this but does anyone have issues with multibutton presses. Specifically with the right trigger and right analog hub on the ICP?  I have that issue. I cannot use right analog and right triiger at the same time. On the latest icp and blutrol versions. Sorry again for posting here
Jun 24, 2013
#66 Gabrial....@gmail.com
matthias update us pleaaase
Jun 24, 2013
Project Member #67 matthias.ringwald@gmail.com
@sgill1036 - I've tried my pre-series iCP and can use the right analog and the right trigger at the same time (there's no reason it shouldn't work)

btw... I've just submitted the Blutrol update with iPega support to BigBoss. Should be live in 24 hrs. Have fun!
Jun 24, 2013
#68 Gabrial....@gmail.com
OHHHHHH YEAH! WAINTING FOR IT! Thannks!
Jun 24, 2013
#69 cartma...@gmail.com
Thank you, Matthias!!! You're the man!!!!
Jun 25, 2013
#71 sgill1036
Thanks Matthias!!! My ICP is very old so i may have gotten a buggy one! Thank you! Im actually switching to Ipega from ICP because of your update. Im going to re-purchase blutrol on another name just to donate 6.99 to you for your attention to your customers. Thanks for making this app. Because of you, i dont play my xbox anymore!!!! I just play blitz brigade with blutrol.
Jun 25, 2013
#72 ameeronl...@hotmail.com
I cant found the updated version on cydia !! Please help how i can found the last version to buy it ??

Sent from iphone
Jun 25, 2013
Project Member #73 matthias.ringwald@gmail.com
Hope you like it!

@ameeronline Blutrol is only available from BigBoss Repo in Cydia. 
Jun 25, 2013
#74 ameeronl...@hotmail.com
@matthias is blutrol now working with ipega control with analogs ?? 

Sent from iphone
Jun 25, 2013
Project Member #75 matthias.ringwald@gmail.com
@ameeronline yes. http://ringwald.ch/cydia/blutrol/


Status: Fixed
Jul 8, 2013
#77 gillesge...@gmail.com
I hvae been trying to connect my Ipega controller for days now and it is not working. It will recognized it but will not connect. I am runing iOS 6.1.3 am I doing something wrong here? I cannot find any blogs on this issue

Thanks
Jul 8, 2013
#78 georgesh...@gmail.com
Are you connecting using the iOS "Settings", or using blutrol?  The proper one is within Setting - blutrol takes over how the iPega interfaces with the device, but is not used for the actual connection.
Jul 8, 2013
#79 gillesge...@gmail.com
I have tried pretty much everything. From going straight to blutrol and scanning for the device this automatically turns of my bluetooth and it those find the device but those not connect. I went into btstack and notice it was on none so tried doing it under IOS and that didnt work. when I went back to btsctack tho it was back on none and it those keep doing that no matter what I do.
Jul 8, 2013
#80 georgesh...@gmail.com
Open Settings and set btstack to use the stock iOS bluetooth stack.  Until you have your device connected within Settings using the native bluetooth don't even open blutrol or btstack: they won't do anything for you until you are already connected.
Jul 8, 2013
#81 gillesge...@gmail.com
Ok so I went to btstack and set it to ios. went to my bluetooth and connected the device. then I went to blutrol and went to controller to connect the ipega. upon doing so I lost connection as original phone bluetooth turned off. turned my device on the be recognized and it found the game pad but cannot connect!!!
Jul 8, 2013
#82 matthias@bluekitchen-gmbh.com
Hi. In general, it's best not to use the BTstack/iOS switch in BTstack settings. (I"m aware that that's not obvious). I recommend to use it only to force BTstack if needed.

Please reboot your device. Then, go to Bluetooth settings. Tap on the blue error and "forget" the iPega. Then pair again.
Jul 8, 2013
#83 gillesge...@gmail.com
Thanks for your response. So let me get this straight i need to repair device with bluetooth and then what? Reason why I ask is because I have done this before. Re paired but when I go to blutrol and go to controller and click ipega then connect, it disconects my device from the bluetooth on my phone, so i then try and make my ipega visible again for blutrol and it finds it but those not connect?
Jul 8, 2013
#84 gillesge...@gmail.com
And just to add when I connect my WII remote it finds it and connects it within seconds so not sure what im doing wrong. Thanks
Jul 8, 2013
#85 matthias@bluekitchen-gmbh.com
Ah! Gotcha. After pairing and connecting to your iPega, you only select it in Blutrol->Controllers. Don't press the connect button, as that shuts down iOS Bluetooth and starts up BTstack. Just go and play :)

Jul 8, 2013
#86 sgill1036
Mr Mathias!  Ipega should pay you for boosting their sales. I switched from icp to ipega cuz of your update. Quick question: when i play blitz brigade (an FPS shooter) i cannot use the right and left joystick with the right trigger. Basically it seems that when i press two buttons simultaneously it works but the moment i use thre buttons simultaneously, it sticks. The letter buttons dont have this issue only the triggers and the joysticks. My ICP had the same issue. Is this a blutrol issue or btstack issue? Thanks again. You will know what I mean if you play an fps game and try to use the right joystick, the left joystick, and the right trigger simultaneously. Thanks
Jul 8, 2013
#87 gillesge...@gmail.com
ok so now doing it without actually connecting threw blutrol and setting up landscape and when i go into nes a.d.x game and i dont get any response. i did press a button and it worked but then stopped and now controllers on iphone work either? any suggestions?
Jul 9, 2013
#88 matthias@bluekitchen-gmbh.com
@sgill1036 - there should be no limit to two controls or so. Can you try, e.g. with a Drums app? I found these very helpful to make sure all buttons work as intended.

@gilles... could you try with a different app? e.g. a Drums app? 
Jul 9, 2013
#89 gillesge...@gmail.com
lol Thanks I got it working. I'm not the sharpest tool in  the shade when it comes to this stuff so thanks for your patients. This is why I play Classic mario bbrothers lol. One last question. is their a way to get the left joystick to work are will it only work with the arrows. Thanks
Jul 18, 2013
Project Member #90 matthias.ringwald@gmail.com
@gilles.. you can map both the left joystick and the d-pad to the screen controls in Blutrol
Jul 18, 2013
#91 ameeronl...@hotmail.com
I wish if there is a one screenshot for mapping buttons to see how we map the buttons exactly and also the left joystick 

Sent from iphone
Jul 18, 2013
#92 gla...@gmail.com
I still have problems to connect ipega in joystick mode. If I just install the "Bluetooth Companion 1.5.2-36" and try to pair the Ipega with the "X+Home" option, is the controller supposed to show up in the bluetooth devices list in the IOS -> Settings -> Bluetooth menu?
Jul 18, 2013
#93 matthias@bluekitchen-gmbh.com
@gla... it should show up with or without Bluetooth Companion or Blutrol. Without Blutrol and Bluetooth Companion, your device will start experiencing severe lags as the HID driver gets overrun.
Jul 18, 2013
#94 gla...@gmail.com
Thanks for the ultra fast response! It is strange because the "Bluetooth Gamepad" shows up with every single option (A - keyboard, B-mouse or Y-icade), but the joystick mode does not appear at all. It appears in the BTSTack, but does not connect.
Do I have to install any additional package for it to be recognized in the "joystick mode". I have a jailbroke device with the 6.1 FW. What am I missing?
Jul 19, 2013
#95 gla...@gmail.com
Just to be more precise: the controller I am trying to pair is the IPEGA 9017 black model. In various reviews of this controller the "Joystick mode (X + HOME)" is described as "Android only". In fact, this mode was never reconized in my iphone 4 (using fw 5.1.1 and 6.1 with jailbreak in both). I have tested with other two iphones 4S (6.1.2 JB and 6.1.3 Clean FW) and in both cases the phone haven't showed the "Bluetooth Gamepad" through the Settings -> Bluetooth in this mode.
Jul 19, 2013
Project Member #96 matthias.ringwald@gmail.com
@glac81 - please enable "Packet Logger" in the Bluetooth Settings and let it search for a bit and then upload "/tmp/BTserver.pklg" here.
Jul 19, 2013
#97 gla...@gmail.com
Here is the file atached.
I deleted my old file, and tried to pair the device in the Joystick mode and the saved the file.
Thanks again!
BTServer.pklg
3.8 KB   Download
Jul 19, 2013
Project Member #98 matthias.ringwald@gmail.com
@glac81 - thanks. Interesting. It shows up with 2504 as class of device, that's why it doesn't list. I'll double check with mine. Please send your Cyida ID to tickets@btstack.uservoice.com - I can provide you with a free license for BTC Mouse & Trackpad - which should allow you to pair in Joystick mode.
Jul 19, 2013
#99 gla...@gmail.com
Hello again. Message has already been sent. I'll report as soon as I test it.
Jul 19, 2013
#100 gla...@gmail.com
Maybe I have an early version of this controller (or a faulty one). Using the BTC Mouse & Trackpad it appears as a valid bluetooth device (starts with mouse). But it does not work as a joystick... it works like a mouse. I will soon update a version of the packet logger file with the ipega connecting in the 4 avaiable options, because it does not work as a mouse with the mouse option (strange again).
Starting to cry already... At least the iCade function is still flawless. But missing the right nub is frustrating.
Jul 19, 2013
#101 Morit...@gmail.com
Hi Matthias

I have an IPega 9017 controller and trying to setup few games with Blutrol. There is only few games which reaction on controller buttons is fast, other reacts with different lags - 1 sec pause before pressing, or remains pressed for 1 sec when button is released, or even both. Also, lags exists in touchscreen when ipega is connected - hid driver is overloaded? I use iOS 5.1.1 on iPhone 4 - may be newer iOS works better with Bluetooth? Or may be this can be solved other way?
Jul 19, 2013
#102 gla...@gmail.com
Here is the file. I have made four operations:

1 - Paired in iCade mode (Y + HOME) then forgot the device;
2 - Paired as a Keyboard (A + HOME) then forgot the device;
3 - Paired as a "Mouse" (B + HOME) then forgot the device;
4 - Paired as a "Joystick" (X + HOME) then forgot the device and turned the logger off.

Already waiting for the worse. Thanks for the help.

Maybe I should buy another unit form DX to see if this one comes right...
BTServer.pklg
56.4 KB   Download
Jul 28, 2013
#103 vodro...@gmail.com
hi i just buy ipega pg-9017 yesterday and i connect with my iphone 4s ios 6.1 in mode "joystick" to play shadowgun but i can't... this mode lag the iphone and i dont know how fix it. in mode iCade work perfect with snes emulator. please help me
Jul 30, 2013
#104 luiseu...@gmail.com
I found the soluciĆ³n... Now i can play modern combat 4 with my ipega controller :)
Aug 7, 2013
#105 gorb...@gmail.com
I also have lag with blutrol + iPega on IOS 5.1 :/
could it be investigated/fixed pls? already opened a issue for it. thx!
Aug 7, 2013
Project Member #106 matthias.ringwald@gmail.com
what iOS devices show the lag? (it's just that they are slower and cannot handle the 60 hz (if I remember correctly)) 
Aug 7, 2013
#107 gorb...@gmail.com
sorry forgot that important thing :D  I have an iPhone4
Aug 7, 2013
#108 gorb...@gmail.com
and this lag also happens with the PS3 controller
Oct 14, 2013
#109 ameeronl...@hotmail.com
@Matthias please help me with ipega with blutrol , I have last update of blurtol and all buttons matched perfect but still don't know how to match the left analog with the camera movement in some games like shadowgan or dead nation !
I have iphone 5 with ios6.0

Nov 21, 2013
#110 gsain...@gmail.com
there is a new ipega controller with more buttons like L2,R2, pause ,play and other buttons.Is there going to be a new version of blutrol form this? it only makes sense.
Feb 4, 2014
#111 josephra...@gmail.com
Hey matthias when are you gonna add the ipega 9025 to blutrols list of devices?
Feb 5, 2014
Project Member #112 matthias.ringwald@gmail.com
I'll add the iPega 9025 with the iOS 7 update of Blutrol. I got one from dx.com last week or so. Blutrol depends on basically all my other stuff which I need to port to iOS 7 first. So maybe end of February would be an optimistic guess. thanks for your patience :)
Feb 15, 2014
#113 josephra...@gmail.com
wait so if i dont have ios 7 on my phone it will not work?
Feb 17, 2014
Project Member #114 matthias.ringwald@gmail.com
@josephram: the update will be for iOS 4-7, don't worry.
Feb 25, 2014
#116 dpece...@gmail.com
How about going Matthiass? 
February is ending and we are excited about the new update, I'm counting the hours to come, which I hope will be as soon as possible. 
Thanks for your work Matthiass, I'm looking out for iOS7 and able to buy. 
A greeting.
Mar 8, 2014
#117 josephra...@gmail.com
any update ?
Mar 21, 2014
#118 gsain...@gmail.com
When is it coming out? 
 
Mar 21, 2014
Project Member #119 matthias.ringwald@gmail.com
well,l when it's done. I hope to finish BTC Mouse & Trackpad this weekend and will look into Blutrol after that.
Mar 21, 2014
#120 gsain...@gmail.com
Needless to say...thank you for the answer and thank you for starting the real gaming movement on ios before Apple theirselves.You should work at Apple and teach them a trick or two bro.
Apr 2, 2014
#122 andreasb...@googlemail.com
is ipega 9025 now supported with the ios 7 update as announced in this thread? :)
Apr 3, 2014
Project Member #123 matthias.ringwald@gmail.com
Hi there. Blutrol 3.5 works on iOS 7. It doesn't have new features, and in fact, misses the ability to use your fingers while playing. It also doesn't add support for the 9025. As people have been demanding, we released the first working version to get some people happy. We'll continue adding new features and controllers to Blutrol step by step.
Apr 5, 2014
#124 JaredWil...@gmail.com
I see that it has compatibility for a Wii remote, and you said a year ago there would be support for a Wii U Pro controller, but did that ever come to fruition?
Apr 9, 2014
#126 dennisad...@gmail.com
i have the ipega 9017 and blutrol says it works but how on earth am i suppose to use the controller if i cant even connect it to my iPhone on joystick mode i don't see the point of even adding the ipega 9017 setting into the app if i cant even use it. I downloaded bluetooth companion that didn't work either and to be honest i didn't expect it to work because the whole blutrol project is useless. I have been very patient but whats the point. Fix the ipega 9017, I could have spent my money elsewhere and i would have got more for it
Apr 9, 2014
Project Member #127 matthias.ringwald@gmail.com
Bluetrol 3.5 with Bluetooth Companion 1.6.1 support the iPega 9017 in joystick and in iCade mode. The iPega 9025 is not supported yet.

I have an Wii U Pro, an iPega 9025, a DualShock 4 at home (in addition to all the other controllers already supported by Blutrol) and still plan to add support for those to Blutrol - preferably by extending Bluetooth Companion so people can keep using their Pebbles, headsets, etc. 
May 23, 2014
#131 vampire...@gmail.com
is there any chance we can use the 2 analog stick of ipega? only the dpad is working

Sign in to add a comment

Powered by Google Project Hosting