My favorites | Sign in
Project Home Downloads Wiki Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 7: Installing Nao Ros driver
2 people starred this issue and may be notified of changes. Back to list
Status:  New
Owner:  ----


Sign in to add a comment
 
Reported by ParkoJan...@gmail.com, Mar 17, 2011
We tried to install the brown's university ros driver for the nao according to the readme in the package.
We tried to install the driver on the original nao image version 1.10.10 and on 1.8.16.
On both we had first the problem that the file paths, which are mentioned in the readme of the browns package to copy the "libbrowneyes.so", aren't existing ("/opt/naoqi/modules/lib"), so we copied the library to "/opt/nao/lib".
The next step was to add the library to the "autoload.ini", which should be loacated at "/opt/naoqi/modules/lib" but was located at "/opt/naoqi/preferences/".
The next step was to copy the "naoros.tar" to the nao and extract it somewhere in the home folder and configure the "envConfig" in "~/naoros/run/".
After sourcing the "envConfig" we started the driver by "./eyes" and got these error messages:

1.8.16:
 "./eyes: error while loading shared libraries: libiconv.so.2: cannot open shared object file: No such file or directory"

1.10.10:
 "Couldn't get shared memory!"

On both firmwares the "urbistarter" library is commented out in the "autoload.ini". Is it required for the driver? On both versions it doesn't make a difference if we comment it in.

Does anyone maybe know what we did wrong? Are the nao image versions we used not compatible with this driver?

We also tried to flash the firmware 1.6.13 but this one is not compatible with the hardware version of our nao robot.
Aug 15, 2011
#1 nickarms...@gmail.com
I notice that there seems to be a hard-coded path near the top of control.py, which points to a non-existent directory (/opt/naoqi/external, I think, but I don't have it in front of me).  When I run control.py, I get SOAP errors of the form "setVolume not a member of tts" and "setStiffness not a member of motion" ...

I have opened up an answers.ros.org ticket in addition to this one, at http://answers.ros.org/question/1864/nao-teleop-and-camera-feed

Thanks for any help!
Sign in to add a comment

Powered by Google Project Hosting