My favorites | Sign in
Project Home Downloads Wiki Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 710: https://www.videotron.com/services/secur/CIUser.do failed to load (ssl)
1 person starred this issue and may be notified of changes. Back to list
Status:  New
Owner:  ----


Sign in to add a comment
 
Reported by bigras.b...@gmail.com, Oct 8, 2009
If you have a webpage rendering issue (aka bug in QtWebKit) it should be
filed on bugs.webkit.org.  If you are unsure you can file it here and we
will let you know.

What steps will reproduce the problem?
1. Go to https://www.videotron.com/services/secur/CIUser.do
2. See the "Failed to load" message in the status bar

What is the expected output? What do you see instead?
It works on Firefox.

What version of the product are you using? On what operating system?
0.10.1 (Git: 1338 f83796a)

Please provide any additional information below.
I had problem with this site when I was doing a KDE 4 plasmoid. At first I
thought that Qt had a problem with https sites and I wasted a lot of time
before figuring out it was a problem only with this site.


'curl "https://www.videotron.com/services/secur/CIUser.do"' output :

curl: (35) Unknown SSL protocol error in connection to www.videotron.com:443

'curl -2 "https://www.videotron.com/services/secur/CIUser.do"' seems to work.

Anyway, for my plasmoid I was able to fix/workaround the problem by forcing
the protocol to QSsl::AnyProtocol:

QSslSocket *socket = new QSslSocket(this);
socket->setProtocol(QSsl::AnyProtocol);
qhttp->setSocket(socket);
Sign in to add a comment

Powered by Google Project Hosting