My favorites | Sign in
Project Home Issues
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 9017: Exchange folders missing
82 people starred this issue and may be notified of changes. Back to list
Status:  Released
Owner:  mbl...@google.com
Closed:  Sep 2010


Sign in to add a comment
 
Reported by Andreas....@gmail.com, Jun 11, 2010
I have about 50 mail folders in my Exchange 2007 account. The folder hierarchy has got max. three levels. Only 20 of them are display on my german Motorola Milestone. The hierarchy and sort order is ignored.
I could reproduce the bug on a HTC Desire.
With other apps like Touchdown, all folders are being displayed.

All folders should display in the right sort order and hierarchy.

Android 2.1-update1
Build SHOLS_U2_02.34.0


Jun 11, 2010
#2 nik.thir...@googlemail.com
I have similar issues with Exchange 2003.

Sort order ignored.

Missing subfolders. I can not see any pattern here.

Motorola Milestone 
Android 2.1-update1
Build SHOLS_U2_02.34.0

Jun 11, 2010
#3 mbl...@google.com
Is this the built-in Email application, or an HTC application?
Status: NeedsInfo
Jun 11, 2010
#4 nik.thir...@googlemail.com
I am using the built in email app on my Milestone.
Jun 11, 2010
#5 mbl...@google.com
(No comment was entered for this change.)
Owner: mbl...@google.com
Jun 11, 2010
#6 mbl...@google.com
If you send me mail, I can give you instructions for generating some logging information that might be helpful in sorting this out.
Jun 11, 2010
#7 sath...@gmail.com
I am using Nexus One with Android 2.2 and i see similar issue. I have a folder with two sub folders in my Exchange account but in my Nexus One the sub folders are not shown.
Jul 2, 2010
#8 nsrder...@gmail.com
problem also exists on HTC Hero, tried Version 1.5, 1.6 and now 2.1

I don't see what the problem should be, It's not folder depth.
i've got folders like;
INBOX/DEPARTMENT/USERNAME1
INBOX/DEPARTMENT/USERNAME2
INBOX/DEPARTMENT/USERNAME3

But all other users are missing, and they are the same depth also is't not the number of characters, because users with a 5 letter name are not shown and users with 12 characters including a space are shown.
Jul 2, 2010
#9 mbl...@google.com
If one of you with a "stock" Android device (i.e. not Hero or other phones with Sense), please contact me via email, and I'll get you logging instructions that might help narrow down the problem.
Jul 12, 2010
#10 netzwer...@googlemail.com
Similar problem here with FRF91 on Nexus One and Exchange 2003. Some folders are missing mostly those with subfolders in there. Seems only leaf-folders are beeing synced despite from the normal inbox.
Jul 14, 2010
#11 nik.thir...@googlemail.com
mbl...@google.com, I have sent already two emails and did not hear back from you about any logging instructions.

Would you mind posting them here directly?
Jul 19, 2010
#12 netzwer...@googlemail.com
Jep. I also sent a mail to mbl... but no response. I REALLY need some of the missing folders. So _please_ make a response.
Jul 19, 2010
#13 mbl...@google.com
I'm sorry I haven't responded; I've just been busy.  I'll send something about logging later today.
Jul 19, 2010
#14 mbl...@google.com
 Issue 5320  has been merged into this issue.
Jul 19, 2010
#15 mbl...@google.com
Here's some info about generating logs for Email.

PLEASE NOTE THAT, DEPENDING ON THE DEBUG SETTINGS YOU'RE USING, IT'S POSSIBLE FOR EMAIL LOGS TO INCLUDE PASSWORDS AND SOME CONTENT FROM EMAILS, CONTACTS, AND CALENDAR ENTRIES.  DO NOT POST OR SEND LOGS WITHOUT ENSURING THAT ANYTHING PERSONAL OR OTHERWISE SENSITIVE IS NOT INCLUDED.

To start Email debug logging, go to the Account screen in the Email application and type "debug" (bring up the soft keyboard, if necessary).  This should take you to a screen with a number of checkboxes (four most likely).   

"Enable extra debug logging" - If checked, this turns on basic logging (no passwords or other content is logged); most useful for debugging crashes.

"Something about sensitive information" (don't have the verbiage in front of me) - if checked, this causes POP/IMAP passwords to be logged.  Exchange passwords are NEVER logged.

"Enable exchange parser logging" - If checked, logs a great deal of the CONTENT of mail, contacts, and calendar entries (excluding the text of emails other than perhaps the first line).   This information (edited to remove personal information) is helpful for debugging things like missing folders (this bug), missing calendar entries, etc.

"Enable exchange sd card logging" - If checked, puts all of the Exchange related logging onto SD card in a file named emaillog.txt.   This file grows continuously until deleted (or the checkbox is unchecked).  This can be helpful in finding issues that are sporadic.

Note that the sd card log can be retrieved at any time by putting your device into USB transfer mode.  Otherwise, log contents must be sent in a "bugreport", and these reports typically only include the most recent 5-30 minutes of activity (so you won't find yesterday's crash in one).

If anyone needs information on obtaining a bugreport, please let me know.
Jul 20, 2010
#16 netzwer...@googlemail.com
Hello!

Thanks for the instructions for the emaillog.txt. But: I'm unable to turn logging of again. If try the same procedure as I did, when turning it on after typing "debug" nothing happens. Even after phone restart. I tried the way over the E-Mail application and also over settings.
The logfile is beeing generated as aspected. I will send it to you when it logs something interesting to this issue.

Tank you
Jul 20, 2010
#17 netzwer...@googlemail.com
OK. Sorry. My mistake. I was in the wrong menu. I was in in Accountsettings instead of Accounts.
Jul 20, 2010
#18 nik.thir...@googlemail.com
mbl, thanks for the instructions.

Which actions do I need to do so that you get the kind of information which you need in the log? I tried to refresh the folders but that does not list all the subfolders in the log file.
Jul 20, 2010
#19 mbl...@google.com
In the case of the folder list, you'd need to re-create the account.
Jul 20, 2010
#20 netzwer...@googlemail.com
Hello mbl,

I've done a re-creation of my account. Maybe I found the reason for this:
Most folders are displayed as "Type: 12" in the logfile. These folders are working fine.
The missing folders are displayed as "Type: 1".

By the way: Notices are Type 17 and 10 and Tasks are Type 7.

If you are interested in the complete logfile, send me a mail.
Jul 20, 2010
#21 netzwer...@googlemail.com
Here is a small part of the log:

[21:33:50] EAS Parser| FolderServerId: ad019299f7f9db45991b482e65a558db-2b0219
[21:33:50] EAS Parser| FolderParentId: ad019299f7f9db45991b482e65a558db-2b0208
[21:33:50] EAS Parser| FolderDisplayName: XING/OpenBC
[21:33:50] EAS Parser| Type: 12
[21:33:50] __eas(koerner@netzwerge.de)| Adding mailbox: XING/OpenBC
[21:33:50] EAS Parser| FolderServerId: ad019299f7f9db45991b482e65a558db-2b021a
[21:33:50] EAS Parser| FolderParentId: f7fbe04a2886bb4b87c2bf33e2958f81-281d
[21:33:50] EAS Parser| FolderDisplayName: Politik
[21:33:50] EAS Parser| Type: 12
[21:33:50] __eas(koerner@netzwerge.de)| Adding mailbox: Politik
[21:33:50] EAS Parser| FolderServerId: ad019299f7f9db45991b482e65a558db-2b021b
[21:33:50] EAS Parser| FolderParentId: f7fbe04a2886bb4b87c2bf33e2958f81-281d
[21:33:50] EAS Parser| FolderDisplayName: Privat
[21:33:50] EAS Parser| Type: 1

Jul 20, 2010
#22 mbl...@google.com
You're right; we don't sync folders of type 1 (which is defined as "User-created folder (generic)"  The reason we don't sync them is that we have no idea what kind of contents they hold.   Type 12 are "User-created Mail".   I'm going to mark this bug as "works as intended", because this really is working as intended.  If you'd like to create an enhancement request for this, feel free to do so.
Status: WorkingAsIntended
Jul 20, 2010
#23 geoff.ri...@gmail.com
That is quite odd. Netzwerghh, are the type 1 folders nested within type 12?
Jul 20, 2010
#24 netzwer...@googlemail.com
Hello Geoff,

my type 1 folders are just subfolders of the inbox which carry other subfolders. I believe that these folders are some really old folders which I created with an really old version of Outlook before I importet my whole pst to an exchange account.
To fix this I did the following:
- renamed the missing folder in something like "foldername_old"
- recreated the folder
- moved all content of foldername_old in the newly created folder
- deleted foldername_old
This made the mssing folder appear in my android mail folders. Well it's just a new folder. But don't forget to have a look at your rules on the exchange server if you have any. Because they have to be changed for the new folder.
Jul 20, 2010
#25 netzwer...@googlemail.com
Thank you mbl for your reply, as I wrote to Geoff I figured out how to solve this. But I think you shold include the type1 folders because they are treated by outlook as mailfolders. But I think they appear only on very old installations.

By the way could you have a look at my Issue 9886 which has to do with calendar and recurring events which start before 1970-01-01 not being synced? I postet the logfile in that issue.
Jul 20, 2010
#26 geoff.ri...@gmail.com
That was why I asked, and I agree. I think they should be included. Or at least put something in there that says, if Folder Type 1 is contained within Folder type 12, then bring over.
Aug 5, 2010
#27 ggood...@gmail.com
I also have folders (all of mine) that don't show up.  Is there a way to change the type in Outlook or someplace?  Having an option to show all these folders would be very nice.
Aug 10, 2010
#29 franz.a....@gmail.com
My Outlook 2010 does not show anything about type 1 and type 12 folders, I can't see any difference in my different Email folders. How is it possible to change a type 12 folder to a type 1 folder? It's just very annoying that I can't see any new mailfolder that I created in Outlook 2010 on my Milestone. When choosing the synchronize task in the folder view on the milestone, the task never ends. Thank you in advance for any help.

Sep 2, 2010
#30 mikecous...@gmail.com
Please re-open this bug.  I can't find a way to create a type 12 folder in Outlook 2010 so I cannot use any of my new sub-folders.
Sep 6, 2010
#31 ReXProdu...@gmail.com
This does need to be changed - There is no simple way in Exchange to change this folder Type and clients like Entourage 2008/(mac) Mail do not create the "Type 12" even when making it a new mail folder.  This folder type is not an issue on Exchange 2003 on android - all folders show regardless of type.

Even if by default these folders do not appear but are allowed to be checked in some settings option that would be a great compromise.  Understandably this is more of a Microsoft Issue than Android, but any client interfacing with Exchange should be required to have the checks in place or gracefully resolve it self better than ignoring the discrepancy.
Sep 6, 2010
#32 nik.thir...@googlemail.com
This is actually what bothers me about Android:

Instead of trying to creat a nice and good user experience *especially* for the average John Doe-user, Android is a geek OS. Even the developers argue about technical details which the average user does not care about - he wants the stuff to be working correctly. Instead he has to deal with "type 12" folders and other non-relevant stuff. See - other OS's and software deal with such type of folders without any issues. 

But Android can not - because from a developer point of view it is not 100% correct.

Sorry, but I do not share this view and philosophy.
Sep 6, 2010
#33 mbl...@google.com
No, you've got that all wrong.  I'm not arguing anything, and I agree that the behavior appears wrong.  All I was trying to do was EXPLAIN the current behavior, since most people who post here are very technically savvy.
Status: Reviewed
Sep 6, 2010
#34 nik.thir...@googlemail.com
Well then you have to explain to us what this status change is about:

"Status: WorkingAsIntended"

This sounds to me like you are not going to change anything since (from your POV) this works as intended. 

Please correct me if I totally misunderstood you ;)
Sep 6, 2010
#35 mbl...@google.com
The status has been changed; it's an open issue in our internal database, and I'm going to try to get additional information about this from Microsoft.  The issue, from my point of view, is whether it's "safe" to assume that type 1 folders contain email, since the documentation is entirely unclear.
Sep 6, 2010
#36 nik.thir...@googlemail.com
Okay, thanks for the clarification.

(Just to add - I mixed up type 1 and type 12 in comment 32, but I think my message went through :) )
Sep 8, 2010
#37 orlith.m...@gmail.com
I just add the same problem.
My mailbox was just upgraded from Notes to outlook.
With build in android email application I can only see the folders I created in Outlook. None of the "Notes" folders can be seen.


Sep 16, 2010
#38 stadlera...@gmail.com
Quick note to those reporting this bug:

If you're seeing this problem on an HTC Desire, or any other device running HTC Sense, then this is one of those rare situations where the same bug is found in two different apps.  Please be sure to report the issue directly to HTC.

We're keeping this bug open of course for Nexus One, Droid, and other devices using the open-source platform email app.

(As with all bugs, if you're seeing the same problems that are already reported, it's much more helpful to simply click "star" than to reply "me too".  The former will keep you notified of updates or new developments;  The latter sends copies of your "me too" to many people who don't really need to see it.)
Labels: Component-Applications Subcomponent-Email
Sep 27, 2010
#39 mbl...@google.com
(No comment was entered for this change.)
Status: FutureRelease
Nov 14, 2010
#40 Eustach....@googlemail.com
Hi there,
I also have the well known problems with different types of exchange-subfolder, I think.
Unfortunately I can't open the debug-window in the mail application, because there is no soft-keyboard available.
Could you please help me?
If I want to access the debug-window, I go into the mail-application then I press and hold the menu-switch!? nothing happenes! If I go into the account setting -> nothing happenes; if I go into the account-manager -> nothing happenes!
The soft-keyboard is exclusively available at textfields!
Device: Samsung Galaxy Tab
Version: Android 2.2

Thanks for your help!
Greeting - E.W.
Nov 14, 2010
#41 mbl...@google.com
Absolutely ridiculous.
Nov 18, 2010
#43 J.Krieg...@googlemail.com
Instead of using such stupid expressions you can just help!
I also have the problem that I can't open the softkeyboard at my Samsung Galaxy Tab. It only opens at textfields! At the galaxy-device there is no key for opening the softkeyboard; if you are longer pressing the menu-button, nothing happens.
Nov 21, 2010
#44 tmcar...@gmail.com
I have a brandnew Samsung Mesmerize with Android 2.1 and am running Exchange 2003 and some of my folders, which are mail folders are missing...99% of them came over; but there are several that did not, and those that did not are a couple of the ones I need... Any suggestions?
Dec 2, 2010
#45 steved1...@googlemail.com
Having the same problem, I am currently evaluation Android as a possible replacement to the corporate iPhones we use at present, and the fact that it will not recognise mail folders that the iPhone will makes Android (which in my opinion is the better OS) a complete none starter as a corporate solution. This is a serious issue if ever you expect Android phones to compete with iPhones or Blackberry's in the business world.

Yes I could create new folders within Outlook 2010 (which creates them as type 12) and transfer the mail across manually, then delete the original folders, but that is simply not a good enough solution.
Dec 10, 2010
#46 andrew.s...@gmail.com
I have 200-odd folders in a max-3-deep hierarchy. iPhone, Touchdown (3rd party android EAS client), Windows Mobile, Blackberry all have no problem seeing the hierarchy & displaying the folders. My Droid 1 running FRG83D (newest 2.2.1 build) still cannot see all folders. Some folders appear and are displayed in strict alpha order regardless of place in the hierarchy. This is a giant black mark against Android for my corporate clients (and for me!) I want to use Android as my only phone, but I still carry a Blackberry because it actually works as an Exchange client. This is really a must-fix. Please do what needs to be done. Thanks...
Dec 15, 2010
#48 kmathe...@gmail.com
No rhyme or reason.I have 4 new Samsung Galaxy Tabs connecting to Exchange 2003. Mine and one other operate as expected, the other two are randomly missing folders. Touchdown can sync all correctly. I recreated one of the problem accounts from scratch and the stock folders were present, but once I restored the contents from a backup PST file, all folders were gone. Not sure how Touchdown has no issues at all. 
Apr 4, 2011
#49 per...@gmail.com
An FYI, OSX's mail application creates folders of Type 1 when connected to an Exchange server and using the "New Mailbox" command.  This was the cause of my issue.  Connecting to Exchange via Outlook and recreating the same folders as stepped through above fixed the issue for me on my Thunderbolt.
Apr 7, 2011
#50 andrew.s...@gmail.com
Still extant in Gingerbread builds as far as I can tell. I'm running a custom 2.3.3 build for the Droid 1 (from Peter Alphonso) and the native EAS client still only shows some folders.
Apr 12, 2011
#51 pf.dam...@gmail.com
I am running Android 2.3.3, Elelinux ROM based on CM7, on my Hero.
I am unable to follow previous instructions << To start Email debug logging, go to the Account screen in the Email application and type "debug" (bring up the soft keyboard, if necessary)>> as unable to bring a keyboard.

I recreate folders new in Outlook and copy mail back in. They are now appearing on my phone. Hopefully I have only a limitd number of folders.

A further issue. I started to create a TEST folder to verify above proceeding. Since, I have deleted that folder in Outlook, but that folder is still present on my phone and I have no found a way to remove it.
May 19, 2011
#52 jtf...@gmail.com
Seeing the same issue using stock Android 2.3.3 on an original Droid and 3.0/3.1 on a Xoom.  Only a handful of older Exchange folders are appearing, rather than the whole hierarchy which shows up perfectly in Apple Mail, Outlook, and on my iPhone/iPad.
Jun 9, 2011
#53 pereir...@gmail.com
Is it possible to provide a date/release when this is going to be fixed? Thanks
Jun 12, 2011
#54 l...@oweitech.com
Hello, what is the current status of this issue and is this information accessible for someone to check on it - is this the only page?

I have a Samsung Galaxy S 4G phone and when I create a folder using Outlook 2011 on MAC it does not show on my phone.

I like android; however, this is inconvenient. I am not sure how to create a type 12 folder. With Outlook web access, I can create a folder which will show on my phone. I am also able to do so on with Outlook 2010 on Windows 7.

If anyone has any helpful info, please share.

Jun 26, 2011
#55 jamesspa...@gmail.com
Please let me add my voice to everyone asking for this issue to be resolved.  My company is looking at which of the new Mobile Platforms we will approve and deploy, and we also like Android.  But this is a problem we can't expect our users to tediously go through renaming and creating new folders.  For, I don,t want to recreate 120 of my 150 or so folders.  Then, even, I'm not sure if that fixes the 'order' issue...  Maybe some are out of order because their parent folders are of the wrong type (according to Google), but I'm not sure. A lot of work to find out.  By the way, this already works properly on all iOS and Windows Phone 7 devices, but as I said, we like Android and need it to work properly, too.  This is a problem with Android an not Exchange.

Jim
Jun 26, 2011
#56 jamesspa...@gmail.com
By the way, folders work right in Touchdown on Android, too.

Jim
Jun 26, 2011
#57 andrew.s...@gmail.com
GOOGLE! GOOGLE! GOOGLE!

ya listening now?

BUY FREAKING NITRODESK! GIVE THEM SOME OF YOUR FREAKING GOOGLE MONEY AND LET
THEM FIX EAS FOR YOU! DO IT! WE'VE SUFFERED LONG ENOUGH! THIS BUG IS OLD
ENOUGH TO DRINK NOW!

thanks!
Jun 26, 2011
#58 andrew.s...@gmail.com
do you think if everybody on this thread tweets this link to Andy Rubin somebody might notice?

@arubin please take a look at https://code.google.com/p/android/issues/detail?id=9017 - Android native Exchange ActiveSync is badly broken for serious corporate users.
Jun 26, 2011
#59 mbl...@google.com
It won't make a bit of difference, because it's well known that AOSP Exchange has some serious deficiencies in terms of folder management.   As the current status implies, this is all actually fixed, but it won't be available until ICS, since the Email/Exchange application isn't "unbundled" (i.e. it can only be updated with an OS update).  We definitely understand the issue, and expect that ICS Email/Exchange will overall be a far better experience than what's available now.  Until then, though, there's nothing to be done (and yes, that's a big shame).

Hope this helps.
Jun 26, 2011
#60 andrew.s...@gmail.com
The information helps. It's nice to know that it's fixed for ICS and I'm looking forward to the release.

I just want the thing to work. And explaining to my users that their shiny new phone won't read their folders and they have to buy a $20 program when the iPhone users next to them have no problems is a little trying.

best regards
Jun 26, 2011
#61 mbl...@google.com
Yes, it's very frustrating (especially to those of us now working on it); we're getting there, though.  I think ICS will be a huge improvement all around.
Jun 28, 2011
#62 andrew.s...@gmail.com
Peter Alfonso of Bugless Beast and GBA fame has offered to try to backport the patch into his GBA Droid ROMS if I can locate the fixed code. Is that something that's possible?
Jul 9, 2011
#63 trau...@gmail.com
OK, at least I've now found the reason for the problem. Whilst Android urgently needs fixing (I can't BELIEVE this is still an issue with 3.1 let alone 2.3.3) for now a workaround would be to change the folder type. Problem is I have been unable to locate a product that can do this and recreating thousands of folders and copying their content and fixing associated rules is not really an option. If anyone knows how please tell!

Jul 25, 2011
#64 farhadta...@gmail.com
Another way I found to get the folders back:

Open MS Outlook:

1. Right click on the folder that is not appearing and click on "Properties"

2. Go to the "Permissions" tab

3. See if your username is appearing in the list. If not, Click on "Add", select your username from the address book. Set the "permissions" drop-down to "Owner" and click on "OK".

Now refresh your mailbox on Android device. You should see the folder.
Aug 11, 2011
#65 rangerss...@gmail.com
I tried changing the permissions to include me as the owner. It did not make the folder appear on the droid.
Aug 16, 2011
#66 mbas...@gmail.com
I also tried (from Entourage 2008 OSX):

* Creating new folder
* Settings permissions

and no additional folders are showing up on my android Motorola XOOM 3.2. I still am not sure why its a problem to show type 1 folders. Every other client I have tried is able to. However their interfaces are designed more towards smaller phone screens and  are not very usable on the tablet.
Aug 16, 2011
#67 mbl...@google.com
We should be showing type 1 folders in Honeycomb; if you like, you could create a log showing the account creation and subsequent few minutes (when the folders would be loaded)...
Sep 15, 2011
#68 pmbjorns...@gmail.com
Re. Comment #66: does this mean that if I don't see the folders now on nexus s, I will not see them in the next version either? I could provide a log..
Oct 6, 2011
#70 gross.0...@googlemail.com
Re. comment #64: changing owner permission of old subfolders works well with Outlook 2010 and Honeycomb 3.2, emails are now synced in that folders.
But due to the fact that I have a hundred subfolders built in older Outlook version I can't change them all and need Googgle to fix that issue.
By the way: I get all folders exchange synced but without structure (all subfolders shown on top level!) and all old built folders are empty (except for the old built folders where I changed the owner permission, these folders now containing emails).
Oct 19, 2011
#71 gross.0...@googlemail.com
Tested some times found that exchange sync with Outlook surely works with android 3.2 on my acer a500 with stock email client. Important to see several emails is the time frame to sync, first times I syncd only last 3 days and wondered why not all emails were syncd;(
But my problem is still that subfolders from Outlook are all placed on top level in my android email client without any folder structure.

Nov 2, 2011
#72 mdhibb...@gmail.com
Soooooooooooooooooooooo!

Is the folder hierarchy going to be fixed?  This thread has been going for well over a year and a half!  I have seen other threads with same issue from back in 2009.  And the best we get is the app is working as intended???

Galaxy Tab 10.1 with exchange 2010
Nov 2, 2011
#73 mbl...@google.com
Folders will appear hierarchically in ICS.
Nov 2, 2011
#74 mdhibb...@gmail.com
Forgive me, but what is ICS?
Nov 2, 2011
#75 mbl...@google.com
IceCreamSandwich, OS 4.0
Nov 2, 2011
#76 mdhibb...@gmail.com
I got it, Ice Cream Sandwhich.  Once ICS is released will I be able to update from Honeycomb to ICS on my Galaxy Tab 10.1?
Nov 2, 2011
#77 mbl...@google.com
That's something that Samsung or your carrier would deal with; hopefully,
they will upgrade their devices, but there's no guarantee.
Dec 15, 2011
#78 ChrisGre...@gmail.com
Still appears to be a problem in ICS on Galaxy Nexus .
Dec 15, 2011
#79 mbl...@google.com
Try recreating the account.
Dec 16, 2011
#80 andrew.s...@gmail.com
Brand new Galaxy Nexus here, Android 4.0.2. Same problem as always. Account was created fresh on the device.

Thoughts? Mine are that I'm incredibly disappointed.
Dec 16, 2011
#81 mbl...@google.com
That is disappointing; is there anything common among: the missing folders?
Dec 18, 2011
#83 andrew.s...@gmail.com
The folders that show up were created in Outlook 2003 and 2010. The folders that don't were copied in Outlook 2003 from an IMAP server to the Exchange 2007 mailbox, just dragged from one folder tree to the other. When the Outlook client was setup to talk to the IMAP server (an old uw-imapd server from Red Hat Linux 7.2), I believe it was told that the server can make folders that contain only items or folders, not items and folders, as that was in fact the case with uw-imapd).

I'd like to stress AGAIN that the native Android EAS client is the ONLY one that has this problem. IPhone EAS works fine, has since iOS 2.0. Nitrodesk Touchdown works fine on Android, and Windows Mobile and Windows Phone have both worked fine in my admittedly limited experience of them. A year and a half since the bug was opened, here we are. Please fix this, it's killing me to have to carry my beat-up old Blackberry just to properly file mail.

I stand ready and willing to help however I can. I control server, client, and phone. Let me know what you need and I will try to make it so.
Dec 19, 2011
#84 mbl...@google.com
You're probably right in thinking that there's something unusual about
those folders (i.e. the ones copied from an IMAP box).   I could help you
get some logs that might show the issue, but I'm skeptical that the problem
can be resolved (i.e. I have no idea what you could do that would change
how these folders look to ActiveSync).
Dec 19, 2011
#85 andrew.s...@gmail.com
OK - fine, the folders are weird. But they're not so weird that EVERY OTHER EAS CLIENT I'VE TRIED can't deal with them. Native Android is the odd man out here. You're writing to a spec, OK, but the spec doesn't match the real world in some significant way, and you need to account for the real world in the same way that EVERY OTHER EAS CLIENT HAS.

Fix the software, guys. Or get NitroDesk to do it. Or something. Until it's done, I will have to add a caveat every time someone asks me what phone to get, and I get asked that a lot.
Dec 19, 2011
#86 mbl...@google.com
If you'd like to provide some logging, let me know and I can provide
instructions (though it will require removing and re-adding the account).
BTW, this threat of yours doesn't exactly help anything (we'd like to fix
bugs as much as you'd like us to); all it does is make me less interested
in helping (it's just human nature).
Dec 19, 2011
#87 andrew.s...@gmail.com
I'm happy to do what ever moves this forward - logging, adding and readding account, anything.

It wasn't meant to be a threat. There's a great article up on the Verge right now about what to tell people who ask what phone to get, and why the answer is often "Get an iPhone." It's because of little glitches like this. I want to tell people to get Android phones. I love Android and the Android ecosystem, and I think the philosophy behind it matches my thinking so much better than any other mobile OS out there. Just the fact that this feedback mechanism exists is so amazing to me - there's nothing like it for the other options. But when stuff like this bug crops up (and stays around for 2 years - my Droid OG shipped with this bug), it undercuts my ability to help people understand why the other stuff matters.

http://www.theverge.com/2011/12/17/2639938/so-what-phone-should-i-buy-and-other-unanswerable-questions

Dec 19, 2011
#88 mbl...@google.com
Fair enough.  We are currently very much restricted in turnaround times for
fixes, as the Email/Exchange app is still tied to the OS, which means that
updates come with OS updates, which are (as you know) sporadic.  The
situation is pretty suboptimal, but that's where we are at today.  Would I
like this to be otherwise?  You bet.

Here are logging instructions.   I'd suggest deleting the account, turning
on logging, and re-creating the account.  After your Inbox starts filling
with mail, the mailbox list has been loaded, so you can turn off logging.
Feel free to look at this; maybe the problem will be obvious; otherwise,
feel free to send it to me directly at mblank@google.com (with whatever
redactions you'd like, obviously).  Hopefully, we can at least find out
what the issue is.

*PLEASE NOTE THAT, DEPENDING ON THE DEBUG SETTINGS YOU'RE USING, IT'S
POSSIBLE FOR EMAIL LOGS TO INCLUDE PASSWORDS AND SOME CONTENT FROM EMAILS,
CONTACTS, AND CALENDAR ENTRIES.  DO NOT POST OR SEND LOGS WITHOUT ENSURING
THAT ANYTHING PERSONAL OR OTHERWISE SENSITIVE IS NOT INCLUDED.

To reach the Debug logging screen:

pre-Honeycomb: Go to the Account screen in the Email application and type
"debug" (bring up the soft keyboard, if necessary).

Honeycomb (tablet): Go to the “Account Settings” screen using the action
bar, then tap “Email Preferences” repeatedly until “Debug” appears in the
account list.  Tap “Debug”.

All phones: From the dialer, dial *#*#36245#*#* (the numbers correspond to
“EMAIL”)

All devices: Go to the account creation screen (method differs depending on
OS version) and enter “d@d.d” for email address and “debug” for password.

Here’s what the checkboxes mean:

"Enable extra debug logging" - If checked, this turns on basic logging (no
passwords or other content is logged); most useful for debugging crashes.

"Something about sensitive information" (don't have the verbiage in front
of me) - if checked, this causes POP/IMAP passwords to be logged.  Exchange
passwords are NEVER logged.

"Enable exchange parser logging" - If checked, logs a great deal of the
CONTENT of mail, contacts, and calendar entries (excluding the text of
emails other than perhaps the first line).   This information (edited to
remove personal information) is helpful for debugging things like missing
folders (this bug), missing calendar entries, etc.

"Enable exchange sd card logging" - If checked, puts all of the Exchange
related logging onto SD card in a file named emaillog.txt.   This file
grows continuously until deleted (or the checkbox is unchecked).  This can
be helpful in finding issues that are sporadic, as the log is essentially
unlimited in size.  Please take care to delete this file when you no longer
need it!

Note that the sd card log can be retrieved at any time by putting your
device into USB transfer mode.  Otherwise, log contents must be sent in a
"bugreport", and these reports typically only include the most recent 5-30
minutes of activity (so you won't find yesterday's crash in one).*
Dec 19, 2011
#89 loay.ow...@gmail.com
This was a major issue for me and I switched accordingly. I hope this gets fixed in the future. 
Dec 21, 2011
#90 andrew.s...@gmail.com
I will make the log soon - I am about to travel for the holidays and this may have to wait until after that. I very much appreciate your taking a look at it and will send it off as soon as I can.
Dec 30, 2011
#91 saba...@gmail.com
mblank,
Is there a technical reason that this has not been fixed?  I have a new Galaxy Nexus with this issue.
When do you expect this bug/enhancement will be addressed and pushed out?
Thanks,
Gadi
Dec 30, 2011
#92 mbl...@google.com
@91 Can you tell me what kind of folders are missing?
Dec 30, 2011
#93 saba...@gmail.com
Ok, I feel like an idiot, but I followed the direction to get to the debug settings. I selected "Enable exchange parser logging", but I have no idea where to find the emaillog.txt file.
The directions seem to neglect to mention any steps after that.  (Do I need to restart?  Do need to root the phone? What?  I cant find it anywhere when I connect it to my computer.)
What am I missing?
I assumed that the folders that are not found are "Type: 1", but I'd love to be able to confirm that.
Thanks,
Gadi
Dec 30, 2011
#94 mbl...@google.com
"Type 1" folders should be ok these days (since Honeycomb).   The file
should be at top-level on your "sd card"; connect your device to a computer
and it should mount
Dec 30, 2011
#95 saba...@gmail.com
Looks like "Type: 1"  AND even "Type: 12" that are sub-folders of "Type: 1".
More information, I tried the workaround from https://code.google.com/p/android/issues/detail?id=9017#c24.
That worked part way - i can now see the folder, but I can't see the messages in it or the old folders that I just moved in to it (I did not recreate) them.
Also, I tried the workaround from https://code.google.com/p/android/issues/detail?id=9017#c64 on the folder "Boston" below.
That did not work at all.  I still don't see that folder.

[13:34:51] EAS Parser| <FolderAdd>
[13:34:51] EAS Parser| <FolderServerId>
[13:34:51] EAS Parser| FolderServerId: 31
[13:34:51] EAS Parser| </FolderServerId>
[13:34:51] EAS Parser| <FolderParentId>
[13:34:51] EAS Parser| FolderParentId: 24
[13:34:51] EAS Parser| </FolderParentId>
[13:34:51] EAS Parser| <FolderDisplayName>
[13:34:51] EAS Parser| FolderDisplayName: Boston
[13:34:51] EAS Parser| </FolderDisplayName>
[13:34:51] EAS Parser| <Type>
[13:34:51] EAS Parser| Type: 1
[13:34:51] EAS Parser| </Type>
[13:34:51] EAS Parser| </FolderAdd>
[13:34:51] EAS Parser| <FolderAdd>
[13:34:51] EAS Parser| <FolderServerId>
[13:34:51] EAS Parser| FolderServerId: 32
[13:34:51] EAS Parser| </FolderServerId>
[13:34:51] EAS Parser| <FolderParentId>
[13:34:51] EAS Parser| FolderParentId: 24
[13:34:51] EAS Parser| </FolderParentId>
[13:34:51] EAS Parser| <FolderDisplayName>
[13:34:51] EAS Parser| FolderDisplayName: Housing
[13:34:51] EAS Parser| </FolderDisplayName>
[13:34:51] EAS Parser| <Type>
[13:34:51] EAS Parser| Type: 1
[13:34:51] EAS Parser| </Type>
[13:34:51] EAS Parser| </FolderAdd>
[13:34:51] EAS Parser| <FolderAdd>
[13:34:51] EAS Parser| <FolderServerId>
[13:34:51] EAS Parser| FolderServerId: 33
[13:34:51] EAS Parser| </FolderServerId>
[13:34:51] EAS Parser| <FolderParentId>
[13:34:51] EAS Parser| FolderParentId: 32
[13:34:51] EAS Parser| </FolderParentId>
[13:34:51] EAS Parser| <FolderDisplayName>
[13:34:51] EAS Parser| FolderDisplayName: RE
[13:34:51] EAS Parser| </FolderDisplayName>
[13:34:51] EAS Parser| <Type>
[13:34:51] EAS Parser| Type: 12
[13:34:51] EAS Parser| </Type>
[13:34:51] EAS Parser| </FolderAdd>

I'll send you the entire log offline.  There is way too much personal information in this file.
Jan 31, 2012
#96 mar...@cellcon.com.au
Log this, email that, remove information.... I just bought the Galaxy Nexus without any investigation into whether the email system would work normally. It's 2012 - the iPhone has been working great for years and years. We have long gone past the days of everyone that has a computer or new phone needs to get a technician to help set it up. I think the Nexus and the operating system is great. I like the phone and what it can do more and more each day - but like others have explained above I have hundreds of email folders and sub folders - it will cost me less to just switch back to my iPhone rather than the hours it will take to "rename" copy emails.... and it still doesn't fix the heirachy problem or make it easy to "sort" emails into folders from my phone. SERIOUSLY - for a non tech head this just seems like it should be a "very" simple fix. How many hundreds of thousands of dollars a year do the script writers for these phones make.... This really is a BIG problem for Android and has been identified a long time ago. I'd really like to keep this phone - but email is way too important and busy for it to be hard work. iPhone, iTunes, iPad synchronisation is so easy - if you are going to compete Android needs to be too.
Jan 31, 2012
#97 mbl...@google.com
This bug is fixed in 4.0.3, for what it's worth.
Feb 3, 2012
#98 andrew.s...@gmail.com
I'm running a 4.0.3 rom on my GNex - Bugless Beast by Peter Alfonso - and it's still a bug. I owe you logs, and I will do it this weekend, just been swamped with the holidays and new business. Be well.
Feb 3, 2012
#99 mbl...@google.com
This is fixed in the next release (hopefully not too long...)
Feb 4, 2012
#100 andrew.s...@gmail.com
Next release meaning 4.0.4? Will it be part of the AOSP tree that most 3rd party ROMs are built from?
Feb 4, 2012
#101 mbl...@google.com
Why wouldn't it be in the AOSP tree?  And if 4.0.4 is the next release,
then yes.
Feb 15, 2012
#102 birger.v...@gmail.com
Only want to add one more case here to emphasize the importance of this issue. And one remark: Nokia hat the same problems with their native exchange clients for years. They have solved the problem with Symbian Belle OS. Ironically, I had decided to move to Android in Dec 2011 after 20 years of Nokia phone usage and bought a Galaxy Nexus running ICS - and was shocked to run into the same problems again. Now, Nokia has solved the problem and I am sitting here with my brand new Google phone fighting again with the same problems... 

Feb 22, 2012
#103 macdonal...@gmail.com
I am having the same issues. I have a Atrix 4g and the subfolders  of my exchange inbox are not showing up. 

If I go to folders on phone only inbox and sent items and a couple of other ones. How do I fix this on phone end or exchange end?
Feb 22, 2012
#104 mbl...@google.com
Atrix uses Motorola's application and we don't support it.  Sorry.
Mar 19, 2012
#105 abitb...@gmail.com
I have the same issue with LG Optimus 4G.  Cannot see my folders that I created in Mac Mail.  I have over 100 folders and don't feel to recreate them.
Mar 20, 2012
#106 Frank.St...@gmail.com
2 years and counting ... That walled garden starts looking more and more attractive. 
Apr 2, 2012
#107 mattygsd...@gmail.com
I loaded 4.0.4 from AOSP on my Galaxy Nexus and I am still having this issue.  I tried the tricks of renaming/recreating the folders and the permissions which did work on the 4.0.3 version from AOSP, but this didn't help on the 4.0.4 at all.  Any other tricks to get this to work until it is officially fixed?
Apr 2, 2012
#108 mbl...@google.com
Have you tried deleting/re-creating the account on device?
Apr 2, 2012
#109 andrew.s...@gmail.com
Same here - Put 4.0.4 on my GNex via Peter Alfonso's Bugless Beast ROM. Email App version is listed as 4.1 in App Info. Deleted and recreated the EAS account. Still no joy with folders. Only the ones that used to show up before show up now - the ones created in Outlook 2010. Anything from older versions is missing, and a folder that I created in 2010 that has folders in it from 2003 crashes the Email app when I select it.
Apr 2, 2012
#110 mbl...@google.com
That's disappointing.
Apr 2, 2012
#111 andrew.s...@gmail.com
I'm generating a log for you now. I deleted the account, rebooted, enabled debugging and added the account. Please look for the log in your e-mail. Thanks for your attention.
Apr 3, 2012
#114 mattygsd...@gmail.com
I have done some further testing and I am able to get folders to show up if at the levels of Test 1 and Test 2 shown below.  I'm not able to get folders at the level of Test 3 to show up on 4.0.4 AOSP.  These are the folders that I could get to show up on 4.0.3 AOSP by either renaming them or recreating them and moving mail into them.  I can see all of the folders in level Test 3 whenever I am viewing a message and want to move it to a folder.  I'll work on pulling some logs now.

Mailbox - user
   Inbox
      Test 1
   Sent
   Test 2
   Managed Folders
      Retention Compliant
         Test 3
May 8, 2012
#115 joshua.l...@gmail.com
I have the same issue with Galaxy Nexus.  Only 1 folder is showing up, I have around 8. 

I then deleted a folder starting with "!!" along with it's subfolders, and now I can see 3 more folders.

But not the one I really need to see.  Tried renaming it, but did not fix it.  

It seems like Touchdown works fine?  Will try that instead.
May 8, 2012
#116 Frank.St...@gmail.com
Yeah, it's pretty pathetic that this has received so little love while it is a pretty essential feature for most business users.
May 9, 2012
#117 henrik.p...@gmail.com
Still broken. Type 1/12 seems to be key, as recreating the folders worked when I did it from the Outlook Web Interface, but not from Apple Mail nor Mac Outlook 2012.

Using Nexus S GSM, stock 4.0.4.
May 9, 2012
#118 farhadta...@gmail.com
i don't think anyone's listening here.
May 9, 2012
#119 nik.thir...@googlemail.com
Lost my hope that this will ever get fixed.
*unsubscribing*
May 14, 2012
#120 gross.0...@googlemail.com
Just got update 4.0.3 on Acer a500. Now I have all my subfolders and everything work well! For me this issue is solved.
May 24, 2012
#121 ban.safe...@gmail.com
Hi. I have 4.0.3 and thought I also had this problem - after a morning of exasperation and on the verge of just giving up, I accidentally found where the folders are!

When browsing the folders on mine, there is nothing to show that Inbox has a number of subfolders ...and if you select Inbox, it simply opens the inbox.  I added myself to the folder permissions, but still the same.

However! When browsing the folders - if I select the Inbox folder's icon, instead of its name, then the list of subfolders magically drops down.  There should really be a plus simple or something on the inbox folder to show this as it's not at all obvious. (Note: The RSS feeds folder does have a + symbol to show that it has subfolders).
Jun 28, 2012
#123 mattygsd...@gmail.com
The issues that I was having previously seem to be resolved in the 4.1 updated for the GSM Galaxy Nexus
Jul 7, 2012
#124 andrew.s...@gmail.com
Running Liquid Vicious v3 Jelly Bean on my Verizon Galaxy Nexus, which includes Email 4.1. I don't know if that's an upgrade from the ICS release, which carried the same version number, but still no joy with the same folders every other EAS client sees without issue. Marc, are you still following this thread? I sent you logs in April per instructions and have heard nothing from you.

Seriously, make the call to Nitrodesk. I've tried running their Touchdown software, but it's overkill for my purposes and it kills my battery life. But they are doing something you're not doing, and their software works where yours doesn't. A little knowledge transfer here will benefit the entire Android community.
Jul 8, 2012
#125 mbl...@google.com
I know this is fixed, but I'll have to check whether the fix made it into
JB (did you try deleting/recreating the account)?

Our problems have little to do with engineering, by the way.  We simply
have no good way of releasing fixes in a timely manner.  It's terrible, and
I hope the situation will improve, but it's... complicated.
Jul 8, 2012
#126 andrew.s...@gmail.com
The account was created fresh on a wiped phone.

There's a lot of variables here. One is I'm running a JB ROM hacked together out of binaries (Liquid Vicious V3) because I'm on a toro GNex, not maguro. So it's not an AOSP compile of JB, since that's not available yet, and it's not a carrier or Google release.

The Email app reports a version number of 4.1 in App Info, but this is notably the same version number it carried in ICS, so it's possible it's either an ICS binary that the people who hacked this ROM together left in, or it's possible that JB includes the same Email app that shipped with ICS. If you or anyone on this thread have a maguro GNex running JB, what version is Email on that?

I appreciate that you have internal issues getting the fixes out, but from an end-user and advocate standpoint, all I see is a known issue that's been around since November 2009, and that refuses to go away. Your first mention of issues regarding releasing fixes is in June of 2011. Here we are a year later, three releases later, still talking about this.

You get how much I love Android, right? That I spent hours loading a hack job of Jelly Bean on my phone just so I could participate in this little adventure? If this is fixed, and didn't make it to JB, I'm not sure what to think.

Jul 8, 2012
#127 mbl...@google.com
It's very disappointing.
Jul 8, 2012
#128 andrew.s...@gmail.com
Does that comment mean you checked and it didn't make it in to JB? Or are you still checking?
Jul 8, 2012
#129 mbl...@google.com
The fix should be in JB, as of JRN33.   It will require re-creating the
account.
Jul 11, 2012
#130 andrew.s...@gmail.com
Just flashed an AOSP 4.1.1 ROM (Bugless Beast, toro, reports Build Number JRO03C). Email App still reports version 4.1. Wiped all data, started fresh.

Bug is the same as ever.

Only folders created with Outlook 2010 show up, all in alpha order. Some folders show contained folders, and I can open the ones that are Outlook 2010-created all the way down. I have a folder called Jobs I created in 2010, and that shows contained folders, but the folders that are in there are older ones that I put in there. When I try to open that folder, Email app crashes and closes.

You tell me, Marc, what should I think? Is the Email binary the same one that's on the Galaxy Nexus you have? What version does a maguro GNex running a stock Google ROM report? Simple question, what's the answer?

Jul 11, 2012
#131 andrew.s...@gmail.com
and by stock, I mean up-to-date Jelly Bean as released in the last day or so.

Jul 11, 2012
#132 mbl...@google.com
Hmm.  I assume its the same.
Jul 11, 2012
#133 andrew.s...@gmail.com
yeah, but who knows? What version is a Maguro Nexus saying it has? Because my machine is behaving exactly the same way it has since Android 2.0 shipped on the Droid OG, and in exactly the way every other EAS client I've ever used isn't.
Jul 11, 2012
#134 mbl...@google.com
I assume it's still broken, then; it would be helpful to see a bug report
(log) of the crash.  I can also take another look, but I'm not sure how to
generate a situation in which the code will fail (cases we've found in the
past have been fixed, but obviously some remain).
Jul 12, 2012
#135 andrew.s...@gmail.com
Marc, if you want to, I am happy to change my password long enough for you to connect to my account and debug away. Email me at andrew @@@ bitboy dot com and we'll set it up. I want this fixed as badly as you do. 
Jul 12, 2012
#136 mbl...@google.com
@135 Done
Jul 13, 2012
#137 frog...@gmail.com
Were you able to determine something wrong, can those of us following expect something to come from @136?
Jul 23, 2012
#138 nathancl...@gmail.com
I'm having the same issue with not all Exchange subfolders appearing on a Google Nexus 7 on 4.1 JB. Anyone else having the same issues? Exchange 2010 here. 
Aug 21, 2012
#139 joost.va...@gmail.com
Mbl, if have a private Exchange 2003 sbs server and have the same problem on a galaxy tab2 7", running 4.0.3.
When i create a folder from the tablet it stays synced.
I wonder, why won't you sinc the type1 folder. If you don't know what it (could) contain, why not just filter out everything except the *.eml and *.msg content.
Seems like an easy way to fix this.
If needed i can create a test account on my server for you to test.
Aug 21, 2012
#140 mbl...@google.com
Yes, that's pretty much what I've decided.
Aug 21, 2012
#141 joost.va...@gmail.com
Lol, any idea what release will contain the fix?
Aug 21, 2012
#142 mbl...@google.com
I assume next major release, whenever that is.
Aug 21, 2012
#143 andrew.s...@gmail.com
So it's not going to make it into Jellybean? not even a point release? Marc, that really kinda sucks. We've been living with this since at least Eclair. At the very least, can you make new Jellybean-compatible APKs that those of us who are rooted can use or that can get folded into ROMs like AOKP, CyanogenMod, or Bugless Beast? I really, really want to be able to file mail from my GNex.
Aug 21, 2012
#144 mbl...@google.com
Yes, it sucks and my hands are tied on this (I can't release apk's, nor can
I get source released before it's generally available).  The issues aren't
technical.
Aug 22, 2012
#145 remotesh...@gmail.com
I have gone to using TouchDown for my exchange server it angers me that after several OS upgrades Android has still not addresses this issue
Aug 22, 2012
#146 mbl...@google.com
It angers me as well, but unless/until Email/Exchange are available on
market (not my call), it's inevitable that third party apps will have much
better turnaround on issues like this.
Aug 24, 2012
#147 andrew.s...@gmail.com
Marc, that's a disingenuous comment. We've known that the issue is Type 1 vs Type 12 folders since mid-2010. You've had more than one chance to get a version of Email included that reads Type 1 folders as mail folders since then. You insisted on writing to a spec instead of the real world, and now, finally, having come around on the issue, blame an inability to release.

But given that fact, who's responsible for making the call about putting Email/Exchange in the market or releasing it into AOSP? If it's not you, who is it? How do we get them involved here? Are there legal issues? Is there licensed code in there that can't be released in that way?

This is a now 3 year-old bug, for which the solution has been in plain sight for over 2. What can we do here instead of just throw up our hands?

Aug 24, 2012
#148 trau...@gmail.com
We can have a laugh.

In some ways it is a shame watching corporations getting bogged down in a
quagmire of inactivity but my experience has shown me that expecting any
organization to move past the traditional model of explosive growth, mid
term complacency and long term stagnation (ending with long painful death)
is unrealistic.

In my youth I was totally amazed that simple code fixes couldn't be
implemented in realistic timeframes. Now I look for the next big thing and
move on. Android is no longer that.
 On Aug 24, 2012 3:49 PM, <android@googlecode.com> wrote:
Aug 24, 2012
#149 mbl...@google.com
@147 Actually, the "spec" doesn't say anything about this, so it is/was a
judgment call; I might have made the wrong one (hopefully, this solution
doesn't cause problems).  As far as putting Email/Exchange in market, I
can't really comment.  [?]
Jan 9, 2013
#150 p...@kaler.com
Marc, can you clarify what the expected behavior is for displaying nested folders in 4.2.1? Are they flattened and listed alphabetically or shown properly nested under their parent folder?

Jan 9, 2013
#151 netzwer...@googlemail.com
They are displayed kind of hierarchically. You have a flat alphabetically ordered list per hierarchy level. When you click a folder you will see a new list containing only the direct sub folders. But still showing you the path to that folder. Just check out the emulator of the ADT. You can see it there.
Jan 9, 2013
#152 andrew.s...@gmail.com
just loaded latest AOKP ROM on my Galaxy Nexus - built from AOSP 4.2.1.

Still no joy on Type 1 folders. Not holding my breath that this will work in 5.0, or ever.
Feb 7, 2013
#153 k...@no-substitute.org
Nexus 7 with JB 4.2.1 Email app version 4.1.
HTC Sensation with Bruce's CM10 v20121221 JB 4.1.2 Email app version 4.1

I can't try the method mentioned in #121. The icon for the Inbox folder isn't clickable.

Changing the folder permissions accomplished nothing.

Creating new folders in either Outlook 2010 or Outlook Webapp (Version: 14.1.438.0) works fine. They sync immediately.

However, if I copy old folders into the newly created folder, only *some* folders where I am set as owner in permissions show up correctly!

Emails already present in the moved "old_folders" show up fine. Copying old emails into a moved old_folder does not always work. LOL - I just realised why! I have sync settings set to only sync 1 month! :-) Ok, next test ...

I changed permissions of all nested folders in my old "hidden" folder, not those nested within the nested, and then moved them all into the newly created and syncing folder. NOT everything shows up! So far it looks quite random what does and doesn't show up. :-(

My conclusion as of today, 2013-02-07:
1. Rename the "hidden" folder. Create a fresh folder with the name of the hidden folder and move your old emails into the new folder.
2. Moving old or nested folders (with correct permissions!) doesn't always work. Try method 1.
3. Method 1 sucks for power users with lots of folders and is utterly useless for administrators, who, as far as I know, can't do this for more than one user, one folder, at the time.
Mar 1, 2013
#154 elfenri...@googlemail.com
SGS2 with CM10.1 / 4.2.2

I observed similar behaviour like #153. In addition, after moving folders with many subfolders on pc to a new (dummy) destination opening them on android even crashs the email app. 
Apr 3, 2013
#155 carlos...@gmail.com
Wow! More than 3 years have passed and this is still an issue?  I just got a brand new nexus 4 and was waiting to get a galaxy note 8. As of now, I can't see 99% of the exchange folders I have (and which my old iphone 3g has been able to see for years), and my ms exchange calendars (multiple entries in one account) don't work at all! This, honestly, is extremely bad. I love the OS, but to have to even read the completely IDIOTIC statements ("works as intended") makes me cringe. I am very close to returning the nexus 4 and buying an unlocked iphone on craigslist. Hate the stupid iOS (bearable jailbroken), but what I *really* need is apps that actually work. the basic functionality of email and calendar in android seems broken beyond repair (more than 2 years and basic stuff still not working). End of rant... end of my feeble attempt to go to android.
Apr 3, 2013
#156 tmcar...@gmail.com
I too feel your pain;  but I just over came it by purchasing  a third party
mail app called  "Touchdown for smartphone" ...which is 100% better than
the native email app..and it works like a charm and I can now see all my
missing folders that has plagued this OS for quite a long time.

Give it a try....I think you will be pleased!
Apr 3, 2013
#157 andrew.s...@gmail.com
The problem with touchdown is that it's a battery killer. It's a great program, but it's a little too complicated for a lot of people and it really does suck down the juice.
Apr 3, 2013
#158 tmcar...@gmail.com
Doesn't take my battery down at all... Im on a Galaxy S3 on US Cellular and
I have NO issues at all.  You have to tweak it and configure by fine
tuning, but its a great program and it absolutely solves this missing piece
of the missing folders issues that the developers of Android have ignored
for way, way, way too long; despite repeated pleas from multitudes of users
asking for a fix...
Apr 7, 2013
#159 andrew.s...@gmail.com
It is a great program. But it's not the native client, and it's not easy to configure. And in my case, it was a huge battery drain.

But the most important thing for those of us supporting tens, hundreds, or even thousands of users in this BYOD world, is that when a user tells me he bought an Android phone and wants to add his Exchange account, there's always got to be this dumb caveat in my head about folders, and I may have to tell him he needs to spend another $20 if he wants it to work right, LIKE EVERY OTHER PHONE DOES OUT OF THE BOX.

Apr 7, 2013
#160 tmcar...@gmail.com
Your absolutely right... and I concur wholehartedly... I do find it to be
quite disengenious this has been on ongoing issue for over 4 years now...
Its quite amazing the Android Devs; or who ever controls the version
changes and adoptions of fixes this has not, nor apparently will never be
fixed...

Not only did I get around the issue with Touchdown for Exchange, I also
have migrated to Exchange 2013, which I have not seen this issue with....
Jun 23, 2013
#161 jbq@android.com
(No comment was entered for this change.)
Status: Released
Aug 1, 2013
#163 tyler.pi...@gmail.com
This isn't fixed, the vast majority of my folders still don't show up on Mail under Android 4.3. I tried recreating my account to no avail. Recreating the folders is not a feasible option as there are too many of them.
Jan 17, 2014
#164 andrew.s...@gmail.com
I now have a Nexus 5 with Android 4.4, and I can officially state that 4 years after the release of the OG Droid with Android 2.0, this bug is finally gone. It's given me hope! My only complaint, and at this point it seems almost churlish to say it, is that when filing mail, 4.4 does the same thing the iPhone does, which is to make me scroll through a list of ALL my folders. It would be nice if it used a hierarchical expand/collapse selector, so I can quickly drill down to the folder I want.

Thanks for the fix Marc.
Sign in to add a comment

Powered by Google Project Hosting