My favorites | Sign in
Project Home Issues
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 68647: NDK make-standalone-toolchain.sh --stl=libc++ fails to create toolchain
1 person starred this issue and may be notified of changes. Back to list
Status:  Duplicate
Merged:  issue 67690
Owner:  to...@android.com
Closed:  Apr 20


Sign in to add a comment
 
Reported by dgiv...@gmail.com, Apr 16, 2014
Host OS: Mac OS X 10.8.5
SDK tools version (available in the "About" section of the 'android' tool
UI): android-ndk-r9d

STEPS TO REPRODUCE:
Try and make a standalone toolchain using libc++:
$NDK/build/tools/make-standalone-toolchain.sh --platform=android-14 --toolchain=arm-linux-androideabi-clang3.4 --stl=libc++

OBSERVED RESULTS:
Copying libstdc++ headers and libraries...
Copying directory: 
  from /Applications/Android/android-ndk-r9d/sources/cxx-stl/llvm-libc++/libcxx/include
  to /tmp/ndk-dgivone/tmp/build-60940/standalone/arm-linux-androideabi-4.6/include/c++/4.6
ERROR: Can't copy from non-directory: sources/android/support/include

ADDITIONAL INFORMATION:
The issue is on line 485 of the make-standalone-toolchain.sh script. The variable $SUPPORT_SUBDIR is relative to the ndk root, so the path is incorrect. Attached is a patch that fixes the issue.
make-standalone-toolchain.sh.patch
666 bytes   Download
Apr 20, 2014
Project Member #2 yukawa@google.com
(No comment was entered for this change.)
Status: Duplicate
Mergedinto: 67690
Sign in to add a comment

Powered by Google Project Hosting