My favorites | Sign in
Project Home Issues
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 39666: GN7/4.2: Unable to add lock screen widgets
46 people starred this issue and may be notified of changes. Back to list
Status:  Duplicate
Merged:  issue 39998
Owner:  ----
Closed:  Jun 2013


Sign in to add a comment
 
Reported by mattwolf...@gmail.com, Nov 14, 2012
I side-loaded 4.2 on my Nexus 7 after downloading from AOSP on 11/13/2012.  Upon reboot, I clicked the '+' lock screen widget box and unlocked my phone (PIN lock enforced by activesync policy).  I was presented with what I now understand to be the available lock screen widgets.  At the time, I was a little confused as to what these four boxes were, so I hit back or home (I don't remember which).  Now, when my screen locks, I no longer get the '+' box to add a lock screen widget and I cannot delete the clock.  If I switch users, everything works as it should.  I've looked through all of the settings and can't find anything related to adding lock screen widgets.  


NOTE: This form is only for reporting user bugs. For all other user
discussions please visit: http://groups.google.com/group/android-discuss

Please describe the problem in detail. Be sure to include:
- Steps to reproduce the problem.
- What happened.
- What you think the correct behavior should be.

Don't forget to mention which device you have, and which version of Android
is installed on it. (Find it under Home > Menu > Settings > About phone.)

If you happen to have a development environment, please also run "adb
bugreport" and archive the output as it could help diagnose the problem.

Nov 14, 2012
#1 mattwolf...@gmail.com
It appears to be an ActiveSync policy issue.  Despite the fact that the '+' showed up after the first reboot, I am able to add widgets if I remove my corporate email account.  I work in the IT department, so I went straight to my Exchange (2010) admin, and we looked over the policy together.  There doesn't appear to be any policies related to widgets or lock screen widgets.  I suspect this is by design, but would like some confirmation.  When I was showing 4.2 to my boss, the first thing he asked was if they would be able to add corporate email to the lock screen.
Nov 15, 2012
#2 s...@stien.ws
Same thing for me. I can't add wigdets because of the activesync security policies. I can understand the need to restrict widgets, but I can't understand why direct access to the camera is restricted as well.
Nov 16, 2012
#3 chpaton
It's particularly unhelpful that there's no UI accordance to explain what's going on. I spent a while swiping the screen various way to try and add a widget and had to resort to reading results pages on Google to work it out. Worse, you can remove the click widget, but it comes back on its own accord when you rotate the screen which seems broken.

Of course, we should be able to add lock screen widgets irrespective of device policy. There's nothing unsafe in allowing me to replace the ugly Android 4.2 clock with a nicer one!
Nov 17, 2012
#4 xauei...@gmail.com
Does this app do the trick? https://play.google.com/store/apps/details?id=com.wordpress.chislonchow.deviceadminkeyguard

This implements new device admin features newly added in Android 4.2. 
Nov 21, 2012
#5 stevew...@gmail.com
in response to the post regarding the Lockscreen Policy app: No, it makes no difference, the policy set by Exchange/ActiveSync overrides whatever is set via that app.
Nov 22, 2012
#6 chadm...@gmail.com
There really should be different classes of widgets, so that class 1 widgets (which show personal information, email, text, etc.) are blocked by the policy, but level 2 widgets (with generic information like the clock) are allowed.
Dec 30, 2012
#7 iuridi...@gmail.com
Same issue here with Samsung Galaxy Nexus with 4.2.1, the "+" box which does nothing if double tapped, held, dragged etc.

Others users are reporting the problem related to cooporate accounts[1], I don't have any.

I also have a Asus Nexus 7 running 4.2.1 without any issues.

1: http://android.stackexchange.com/questions/33361/n7-4-2-cant-add-lock-screen-widgets


Apr 5, 2013
#10 rand...@gmail.com
I've confirmed with my IT admin (we're on Office 365) that the have NOT disabled camera or widgets.  The only thing they require is PIN.  However, my 4.2.2 Nexus 4, when I configure my work email to exchange thinks that camera should be disabled.

Please describe the problem in detail. Be sure to include:
- Steps to reproduce the problem.
configured with work exchange email with only PIN security required
- What happened.
PIN security required, but also disables camera access from lockscreen and lockscreen widgets
- What you think the correct behavior should be.
Only the security defined by the IT admin should be set on the Android phone. In this case, only PIN.  So Camera and widgets from lockscreen should NOT be disabled. 


See attached.
Screenshot_2013-04-05-09-51-33.png
439 KB   View   Download
Jun 23, 2013
#11 jbq@android.com
(No comment was entered for this change.)
Status: Duplicate
Mergedinto: 39998
Jul 30, 2013
#12 larz.jen...@gmail.com
I can confirm this is still an issue under Android 4.3 on my Galaxy Nexus.  Problem goes away as soon as I remove my corporate exchange account, and returns as soon as I re-add it.

Jul 30, 2013
#13 tomas.mi...@gmail.com
Same here with Android 4,3 and corporate Exchange account.
Aug 23, 2013
#14 rand...@gmail.com
If Google wants greater penetration to the business user market, they really need to fix this.  iPhone has non problem w/ their camera being disabled b/c of the exchange policy FYI
Sep 26, 2013
#15 mie...@gmail.com
Agreed. It is disappointing that the camera is not accessible without, in my case, 7 clicks. Short of not having work email and calendar accessible on my phone, I have no choice in the matter. Since this is a corporate phone, I am tempted to switch it out for an iPhone 5S. It's funny that a seemingly small usability issue could cause me to switch, but this is driving me crazy since I use the camera all the time.
Sep 26, 2013
#16 tomas.mi...@gmail.com
Just checked in my company how lockscreens of iPhones with iOS 6.13 and iOS 7 behave. And you can access calendar, camera in lock screen.

Seems that iOS is more friendly to corporates than Android.

-> #15
I fully understand you :) Have some thoughts about 5S as well :)


Nov 7, 2013
#17 NL.digit...@gmail.com
I have a college with Nexus 4 (stock Android 4.2.2) and he also has this problem apps disapear from the unlock scren after adding an exchange account, however my HTC One (stock Android 4.2.2)does not have this problem i can add any app to my unlock screen (camera, mail, G+) evan after adding an exchange account to my HTC One, our company uses Exchange 2010.
Nov 7, 2013
#18 rand...@gmail.com
I just installed the mail app from Kitkat, provided by androidpolice.com here:  http://www.androidpolice.com/2013/10/31/apk-download-heres-the-default-email-app-from-android-4-4-with-gmail-style-ui-and-a-slide-out-menu/

It totally works now!  I have my exchange email, and my camera lockscreen widget!  Make sure you download the mail app from the article, as well as the file needed for exchange email in the comments
Nov 8, 2013
#19 stevew...@gmail.com
Regarding the kitkat update from android police - I've found it does not support the enforced SD card encryption policy on my Galaxy Nexus (no SD card) - and the widgets are not available anyway :(
Sign in to add a comment

Powered by Google Project Hosting