My favorites | Sign in
Project Home Issues
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 38170: VAO objects seems to not working properly in some devices
4 people starred this issue and may be notified of changes. Back to list
Status:  New
Owner:  ----


Sign in to add a comment
 
Reported by calet...@gmail.com, Oct 4, 2012

In Samsung Galaxy Nexus the VAO objects are not binding the vertex attrib data to the context and not enabling them when rendering using glDrawElements.

In Nexus 7 is working properly. I have used GL tracer in both devices and whilst in Nexus 7 was properly binding the vertex attrib data and enabling the correct locations, in Galaxy Nexus was not doing anything before rendering.

So, it seems a problem with the driver that, at least in this device, is not doing what is expected for VAO objects.

If I set the vertex attribs and I enable them before rendering it works fine.

- Which version of Android you're using
4.1.1

- Which hardware you're using
Samsung Galaxy Nexus

- Whether your issue exists both on a device and on the emulator
I have not tried the emulator. But I have tried the code in Nexus 7 and it works as it should be. I have used the GL tracer in both devices.

- Steps to reproduce the problem
Create a VAO with several objects and render them. If possible render other non VAO projects for changing the vertex attribs and see the VAO attibs are not set again.

- Sample source code demonstrating the problem
I can not share the code due is confidential.

- What you think the correct behavior should be
It should change the vertex attribs and enable them automatically if I render a VAO object because it is supposed VAO objects are basically for this.

Nov 1, 2012
#1 nikita.leshenko@gmail.com
I had this issue too. While porting a C++ game from iOS using NDK, the rendering on Galaxy Nexus was incorrect.
Since the game rendered correctly on iOS and since disabling VAOs made the problems go away, I believe that the driver is the cause.
Nov 1, 2012
#2 nikita.leshenko@gmail.com
IMG confirmed it as a driver bug:
http://www.imgtec.com/forum/forum_posts.asp?TID=2324&PID=7221&SID=2220172e1z16a3a579c73bcf253z86443865741&title=vao-not-working-properly-in-samsung-galaxy-nexus#7221

They said they fixed it in rev 1.8@938326. Currently my GNexus (4.1.2) has 1.8@905891.
So yeah... we have to wait.

Sign in to add a comment

Powered by Google Project Hosting