My favorites | Sign in
Project Home Issues
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 3764: Google Maps fails via mandatory web proxy
48 people starred this issue and may be notified of changes. Back to list
Status:  Declined
Owner:  ----
Closed:  Dec 2011


Sign in to add a comment
 
Reported by jimc.ucl...@gmail.com, Sep 2, 2009
    Context: HTC Dev Phone 1 (G1) with Android v1.5 "Cupcake", Google Maps 
v3.1.2 (according to aTrackDog, version not available in settings/apps), T-
Mobile "Sidekick" cell service (symptom seen after about 2009-08-01).  
    Symptom: Previously unseen territory has no maps.  Cached map tiles 
are displayed normally.  No traffic overlay or street view.  Interpreted 
as failure of transport on port 80 to the Google Maps servers.  Also 
transport failure on 80 and 443 to *any* webserver, but that's off topic 
for this bug report.  The weasels blocked the ports and are now insisting 
that you go through their proxy.
    Workaround #1 (failed): Configure T-Mobile's Sidekick proxy server.  
It does the WAP thing, and suppresses images including advertisements 
because a real Sidekick can't display them.  Still no maps.  
    Workaround #2 (failed): I set up a Squid web proxy on my home server, 
and I configured it as the generic proxy in settings/mobile/APN.  This 
brought back generic web service on 80 and 443, including (most) sites 
that require authentication and session cookies, but still no maps.  
    Workaround #3 (partial success): Most people will need the JesusFreke 
or Haykuro hacked Android images to do this, but as an experienced kernel 
hacker, I was able to compile an instance of tun.ko that would load on the 
stock kernel.  (Procedure documented elsewhere.)  Then I installed the 
"VPN Connections" app by Wade Mealing from the market, and configured it 
to successfully connect to a Cisco 3000 at work.  Maps are back in 
action.  This workaround is not practical for ordinary users of the G1, 
particularly if they lack a dev phone.  There's also the detail that the 
vpnc backend shuts off whenever the phone goes to sleep, and you have to 
be root (i.e. adb shell; su root) to start it; making it setUID/setGID 
root.net_raw is ineffective (I copied it to /system/local/bin with a 
symlink because /data is mounted with -o nosuid.)
    What I would like the Android developers to do:  Cause the Google Maps 
app to be aware of and to use the system's global proxy settings.  In 
Squid forums people say that Google Maps for Windows, Mac, etc. do the 
same thing, ignoring the proxy.
    I imagine the developers for Google Maps thought, the desired 
coordinates are appended to the URL as a query-string, so caching is 
impossible, and therefore a proxy should never be used.  Wrong.  Besides 
caching, web proxies are used to enforce policies for security and/or 
profit maximization.  But the tiles are nearly immutable and Google could 
give betters service with less in-house resources if they could be 
cached.  I (and other forum posters) can give some suggestions how to do 
that, but it's off-topic for this bug report.  
    Could the Android helpdesk manager please forward to the Google Maps 
people a link to this bug report, since their reporting interface http://
maps.google.com/support/bin/request.py?contact_type=mbug has no textarea 
to actually report anything.  

Sep 4, 2009
#1 jbq+legacy@google.com
(No comment was entered for this change.)
Labels: Component-Google Subcomponent-Maps
Sep 4, 2009
#2 mdz...@gmail.com
I can confirm this as well.  The Maps application does not seem to honor the system's 
proxy setting, so if the APN requires one, it still tries to connect directly (and 
fails):

19:07:54.316223 IP 10.192.135.21.44840 > 74.125.19.105.80: S 3242606824:3242606824(0) 
win 5840 <mss 1460,sackOK,timestamp 4240328 0,nop,wscale 1>

Sep 6, 2009
#3 jimc.ucl...@gmail.com
See  bug 3803  ( https://code.google.com/p/android/issues/detail?id=3803 ) for the hack 
needed to compile a kernel module that will load.

Nov 13, 2009
#4 py.ricau
I confirm this. Google Maps doesn't use the global proxy settings of the phone. It's
not only the Maps Application, but any application that uses the Maps components.

It seems that the Maps components (MapActivity, MapView) use HttpClient instances
that are not well configured.

If confirmed, the fix should be pretty straightforward :

DefaultHttpClient client = new DefaultHttpClient();

String proxyHost = android.net.Proxy.getHost(context);
if (proxyHost !=null) {
  int proxyPort = android.net.Proxy.getPort(context);

  HttpHost proxy = new HttpHost(proxyHost, proxyPort);

  client.getParams().setParameter(ConnRoutePNames.DEFAULT_PROXY, proxy);
}

So I think the issue is not linked to any kernel module, but rather that some changes
are needed in the Google Maps Android API.

Please anyone star this issue if you encounter the problem ;-) . I think we are a lot
around there to use HTTP proxies when developing.

Nov 13, 2009
#5 py.ricau
There is also a thread on android-developers mailing list on this subject :

http://groups.google.com/group/android-developers/browse_thread/thread/7b170dcf7b807591/c0c6261b01472765
Dec 24, 2009
#6 sam.dutton@gmail.com
I can confirm this: on the emulator, Google Maps only shows blank tiles, and so does the 
Hello, Map View tutorial example.  

I'm using the 1.5 Google APIs SDK, from Eclipse Galileo, on Windows XP SP3, behind a 
corporate firewall.

I've tried two methods to add proxy information:

Add -http-proxy http://www.foo.co.uk:80 to Additional Emulator Command Line Options in the 
Target Page in Debug Configurations.

Remove settings in 1. and add proxy information at Home > Menu > Settings > Wireless 
Controls > Mobile Networks > Access Point Names.

The browser in the emulator works fine and Hello, Map View example works fine on a phone.
Jan 8, 2010
#7 joe.trav...@gmail.com
I can confirm this is an issue with 2.0 as well.
Apr 19, 2010
#8 sergi...@gmail.com
It seems that only the browser uses the global apn proxy (in 1.5).. In 2.1 I've heard
that no application uses the global proxy.. We are in 2010, even dumbphones are
capable of data via proxy. :(. This must be on google todo list with high priority
(same with RFE: Support install of apps on SD cards )
Apr 22, 2010
#9 rsdso...@gmail.com
I had a problem with the "Hello, MapView" example, with the Map coming up empty (as
Dutton explained above). Not sure if it's the same problem given in this thread, but
if anyone does come across the former, you can refer to:
http://www.mail-archive.com/android-beginners@googlegroups.com/msg12216.html

"...you have put the Internet permission under the application, it should be under
the manifest,..."
May 21, 2010
Project Member #10 morri...@google.com
The Android team is not able to help with issues related to Google's 
software for Android, such as Maps.

Please direct questions to the Help Forum:
http://www.google.com/support/forum/p/Google+Mobile/label?
lid=7f2d58e135a03f76&lid=551c5c4cca827a18&hl-en
Status: Declined
May 22, 2010
#11 morri...@gmail.com
To be more clear, this is the bug tracker for the Android Open-Source 
Project. Google's "branded" apps like Maps, YouTube, Gmail, and so on are 
not open-source and are developed by different teams at Google, who do not 
check this bug tracker. Anything about those apps submitted here simply 
won't be seen by the right people.

As we tidy up the Android bug tracker, we're directing issues about the 
Google apps to the Help Forums where the right people will see the 
feedback.
Jun 22, 2010
#12 Brett.Pr...@gmail.com

I am using an APN to access our mobile network that requires a proxy to be used. Currently a number of applications that fail to connect due to a lack of proxy awareness. These applications work fine over WiFi or using an alternative APN that does not require a proxy. 

It seems to me that expecting every application developer to setup the proxy configuration in their application is not ideal. A number of applications don't do this including Google Apps, Google Maps, Facebook client, and the Twitter client. 

It would be really good for us if there was a way to force applications to use the proxy. I have seen this done before in Windows systems by inserting a shim into the network driver stack.  
Jun 22, 2010
#13 Brett.Pr...@gmail.com
 Just to clarify my previous comment the Wifi connection I was using does not require a proxy server to reach the Internet. As far as I know you cannot specify proxy settings for WiFi network connections. 
Jun 23, 2010
#14 py.ricau
By the way, using the proxy parameters in an app is not *that* easy, because the proxy parameters are specific for each connection... We have to check for Proxy param everytime the connection type is changed (WiFi, APN..)
Jul 3, 2010
#15 Raymonddull
The original poster said he tried using the sidekick proxy and it reformatted the pages,could you please share the proxy address? I've been looking for it since tmobile killed the unproxied internet and i can't find it anywhere,the closest I got was the project p1nksn0w thing for iPhone,but the guy never replied to me with what it is. Could you please either post it here or email it to me? it's my username on here at gmail.com.
Jul 5, 2010
#16 jimc.ucl...@gmail.com
@Raymonddull: Sorry, last year in a cleanup campaign I lost my notes on the T-Mobile APN and proxy address.  I originally found it via Google search, I think with keywords "T-Mobile" sidekick proxy.  My resolution was to switch to AT&T GoPhone with the $20/100Mb feature pack once a month. 

Oct 30, 2010
#17 khuns...@hotmail.com
Thank rsdsouza for your comment#9 "...you have put the Internet permission under the application, it should be under the manifest,...".

Now I can display map by following your comment.

Jan 6, 2011
#18 tonie.hu...@qisda.com
I would like to know if this issue is fixed or not ?
I am also suffering in this issue.

Jan 6, 2011
#19 dhanapra...@gmail.com
I too face this issue. Can you please help?
Feb 26, 2011
#20 Alok.Sha...@gmail.com
Anyone found a solution to this? Im using a proxy to access the internet. My AVD's browser is able to access the net, but neither the pre loaded app, nor any app that uses the map view is working...just empty tiles appear..i used both google API level 8 and 9...any fixes for this?
Mar 11, 2011
#21 nrulan...@gmail.com
There nothing to be configured like apn settings or http-proxy. You need to have apiKey. Here is the procedure(Windows OS):-
1. Run Cmd.
2. Locate debug.keystore file (probably it may be=C:\Documents and Settings\Administrator\.android)
type in CMD--->cd C:\Documents and Settings\Administrator\.android
3. CMD--->keytool -list -alias androiddebugkey -keystore debug.keystore -storepass android -keypass android
4. it will generate a MD5 fingerprint.
5. submit it to http://code.google. com/android/maps-api-signup.html
6. you will get a api key.
7. Add it to your MapView
android:apiKey="XXXXXXXXXXXXXXXXXXXXXXXXXXX"
Jun 22, 2011
#22 purnendu...@gmail.com
I am having the same issue. I am behind a corporate firewall, which most of big companies would have. The MapActivity still does not work on emulators needing proxy.
Jul 20, 2011
#23 crazyra...@gmail.com
i've tried this and generated api but still its not working..showing only the tiles 
Jul 20, 2011
#24 success....@gmail.com
starting google map api avd with -http-proxy switch from command line has
solved this problem for me.

-- 
Thanks for Cooperating!
 Anil Kukreti

We are not here for making a history.
We are here for making a future. !
09717125554
09312646623
Linked In : http://in.linkedin.com/in/anilkukreti
Blog : http://androidosbeginning.blogspot.com/
Skype Id : anil.kleward
Dec 6, 2011
#25 emreerke...@gmail.com
thank you for comment #21. It helped me to solve problem. The only reason for this problem is that we are not using the correct keystore. We need to use android's debug.keystore file to get MD5 fingerprint. Thank you again..
Sign in to add a comment

Powered by Google Project Hosting