My favorites | Sign in
Project Home Issues
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 36638: Android 4.1.x Jelly Bean does NOT connect to 802.1x/PEAP WiFi networks
41 people starred this issue and may be notified of changes. Back to list
Status:  New
Owner:  ----


Sign in to add a comment
 
Reported by cgatno, Aug 23, 2012
I have a Galaxy Nexus running Android 4.1.1 Jelly Bean. Details are below:

Please describe the problem in detail. Be sure to include:
- Steps to reproduce the problem:
In order to reproduce this issue, simply find a 802.1x WiFi network. For me, this network is located at my school (Duquesne University). Attempt to connect to the network using correct credentials and other settings.
- What happened:
Upon completing the steps above, the network status will read "Connecting..." for a period of time then there will be no status (it just indicated the network is saved). Android will continue to attempt to connect to the network, and eventually it will stop and the status will read something along the lines of "Authentication Error".
- What you think the correct behavior should be:
The correct behavior would be for Android to connect to the WiFi network successfully, allowing me to fully transmit data.

A few side notes:
-My device will connect to networks with other types of protection (WEP, WPA, etc.) just fine
-When my device was running Ice Cream Sandwich (Android 4.0.4), it was able to connect to 802.1x networks normally
-I have talked to other people with devices running Jelly Bean who have the same problem (they can't connect to any 802.1x networks)
-All other smartphone users (iPhone, Windows Phone, Android 2.x-4.0.x) can successfully connect to 802.1x networks (including the one I have been trying to connect to)
-I have confirmed that my account credentials are correct and in the system, ruling out the possibility of that being the problem

As soon as possible I will collect a log and post it here. This issue is VERY important to myself as well as many other people! It's not a deal breaker because Jelly Bean brings so many awesome features to the table, but it is a pretty vital aspect that I need to have working on my devices. Please take a look at this issue, and thanks in advance Android team!

Sep 25, 2012
#2 kristian...@gmail.com
Same here. I have a Galaxy Nexus and a Nexus 7, both running on Android 4.1.1 Jelly Bean. Can't connect to a 802.1x WiFi network.
Sep 25, 2012
#3 mwag...@gmail.com
I have four new Samsung Galaxy S III phones that are exhibiting the same behavior, only with ICS. I have an older phone running Gingerbread that connects and transmits without issue. I've yet to find a solution searching sites, but this appears to be a software problem as it occurs across different phones. Our setup is:

WPA2-Enterprise/802.1x, AES, PEAP, EAP-MSCHAP v2

The S IIIs "connect" to the WLAN, but are unable to pass data. Unlike the original poster, iPhones connect without any problems. 
Sep 25, 2012
#4 cgatno
Hmmmm strange that it's not working on a Samsung Galaxy S III with ICS. Probably a Samsung skin issue since, from what I've heard, other ICS devices have not had this problem. Also, I indicated iPhones COULD connect to the network, isolating this as an Android issue. Originally I thought it was Jelly Bean-only, but it appears to be on your ICS Samsung Galaxy S III. Once again, I'm guessing that's the fault of Samsung, whereas the Jelly Bean problem happens across all Jelly Bean devices, indicating a problem in the source. I REALLY hope Google clears this issue up soon. Until then, if anyone experiencing the issue has a custom recovery installed, check here for a fix: https://code.google.com/p/android/issues/detail?id=34212#c10

I plan on looking into this more and contacting a few people about it.
Sep 27, 2012
#5 denis.r...@gmail.com
Have the same issue now, after upgrading from GingerBread to ICS 4.0.4. Motorola Droid XT910, would not connect with PEAP and MSCHAPSV2. Used to work with GingerBread no problems. Now it jsut saying Connecting... Saved. Auth Error. | Repeats non stop.
Sep 27, 2012
#6 mwag...@gmail.com
One of the recipients of one of the GS3 phones has a Droid Razer Maxx running 4.0.4 and I was able to get it to connect to our corporate WLAN without a hitch. Very strange. I was thinking something is either flaky with the hardware or more likely with whatever tweaks Samsung has done with the GS3. These phones aren't unlocked or rooted, so I can't really try out any of the patching methods suggested. I guess it's just a waiting game until it gets fixed by whoever thinks it's their issue to fix.
Oct 17, 2012
#8 cgatno
Just so everyone knows, the issue seems to be fixed in the Android 4.1.2 update rolling out to Nexus devices. I know this doesn't help everyone, but at least we know going forward (future Android devices/versions) it shouldn't be an issue. You can use the fix posted in my comment above or contact your device manufacturer if you do not have a Nexus device.
Oct 18, 2012
#9 christop...@gmail.com
It seems the issue is not fixed on the Nexus 7 though... my S III has no problem whatsoever connecting to the wifi network at university, whereas my Nexus 7 seems stuck at authentication... :-(
Oct 18, 2012
#10 Chancov...@gmail.com
I too had a WiFi problem on my nexus 7 when connecting to university WiFi on 4.1.1 but that problem has been fixed for me on 4.1.2
Oct 20, 2012
#11 paul...@gmail.com
My stock Nexus7 received OTA 4.1.2 and installed - works fine on home secure network but fails at university WiFi (I think ssl authorization) fails to display page to complete connection.("insecure connection - do you accept-" sign in page) Just clarifying not everyone with Nexus7 upgrade experiencing satisfactory resolution.
Oct 21, 2012
#12 TestSubj...@gmail.com
it worked at first with 4.1.2 than battery ran out while connected and now... Still forever "connecting"
Oct 21, 2012
#13 cgatno
Hmmmm interesting. To the people who are on a stock Nexus 7 running 4.1.2 and are still having trouble connecting: try clearing your cache and dalvik cache through the android recovery menu and see if it helps. My friend did a fresh install of 4.1.2 on his Nexus 7 using the factory images on Google's website, and now the WiFi problem is totally fixed for him. If anyone wants to try wiping cache and dalvik cache and you need help, just reply here or try to Google it.
Oct 24, 2012
#14 rjgreenf...@gmail.com
have a stock nexus 7 with 4.1.2 and cannot connect to work wifi WPA /TKIP. I am forever "connecting" , I wish. Google please, please, please sort this out.
Oct 24, 2012
#16 cgatno
Hmmmm interesting. Well thank you for trying that. For the people still having issues, in order to diagnose the problem you'll have to complete the following steps:
1) Be at the place where your WiFi will not connect
2) Turn WiFi OFF on your device
3) Restart your device (full restart - power it off then turn it on)
4) Turn WiFi ON on your device
5) Attempt to connect to the problematic network. Allow your device to attempt to connect for about 30 seconds
6) While the device is still attempting to connect, save a logcat from your device
7) Post the logcat here, along with your device name and the version of Android you are running (as well as any modifications to your device/software if applicable). Also include a description of the network you are attempting to connect to (please be as specific as possible). 

If someone decides to run through these steps, I can try to diagnose the problem and produce a fix. Good luck!
Oct 26, 2012
#17 rjgreenf...@gmail.com
Hi tried to follow steps in comment 16 but without a successful connection, how exactly do you produce a Logcat ??

Oct 26, 2012
#18 cgatno
Even without any connection, you should be able to get a logcat through several ways. You can use an app (such as aLogcat) or you can connect your device to your computer and obtain a logcat via ADB.

http://wiki.cyanogenmod.com/wiki/Logcat
Oct 30, 2012
#19 hrvoje.k...@gmail.com
I can report that I have same problem on Xoom with both ICS and JB (4.1.1 and 4.1.2.) on my college. 
We are instructed to enter following config into Wifi Advanced Config App:
SSID: FERwlan
EAP: PEAP
Key Manegement: IEEE 802.1X
Pairwise Chipers: NONE i TKIP
Authentication Algorithms: OPEN i SHARED
Group Chipers WEP40 i WEP104
Allowed Protocols: WPA i RSN
"Phase2": MSCHAPV2
On previous androids (up to 2.3) it worked perfectly. On ICS and above app doesn't save those settings. Tried with Full Wifi app with same result. Tried to root and change wpa_supplicant.conf directly, but that just disabled my wifi completely.
It's very frustrating since college is primary location where I use tablet. hope this gets fixed with 4.2. 
Oct 30, 2012
#20 a0923...@gmail.com
Same here. I have a Nexus 7, running on Android 4.1.2 Jelly Bean. Can't connect to a 802.1x WiFi network.
Nov 2, 2012
#21 specialf...@gmail.com
I have the same problem with my stock Galaxy Nexus phone running 4.1.2.  I get the message that says 'authenticating' over and over but never connects to the Cisco router.  This router is at work and I do not have the ability to change the settings, all I can do is power cycle it but still no joy.  
Nov 4, 2012
#22 cgatno
Very interesting, as my Galaxy Nexus is also on 4.1.2, but the original problem is completely fixed. Once again, if you guys can provide logcats with your router/connection settings we can try to come up with a fix.
Nov 8, 2012
#23 alal...@gmail.com
ok guys, i'm attaching some logs from JellyBean 4.1.2's wpa_supplicant here in my school (Northeastern Univ) where this problem manifests again and again. With jellybean 4.1.2 at least my phone does connect, but I do get dropouts every now and then and the logs will demonstrate that.

the pcap file shows the exchange that happened when lines 18-21 in to-send.txt were logged. 

Lines 14 and 15 show the log when the drop happened. I don't understand how authentication can fail after being successful? When line 15 happened, my wireshark dump showed absolutely nothing so there wasn't even an exchange between the router and my phone.

Hope you guys can fix this! In JB 4.1.1 I wasn't able to connect almost at all.
to-send.txt
5.3 KB   View   Download
to-send.pcap
674 bytes   Download
Nov 8, 2012
#24 cgatno
Hmmmm interesting. Thanks very much for taking the time to attach your logs, I'm going to take a look at the code tomorrow and will let you know what I find. Just a few questions though to verify:
You're running stock 4.1.2 on a Galaxy Nexus, right?
Also, when you say you get dropouts "every now and then," do you mean you are able to connect to and use WiFi over a period of time before it drops out, or does it drop out almost immediately after connecting?
Nov 9, 2012
#25 victor.l...@gmail.com
very interesting, My nexus 7 is also meeting this problem, after 4.1.2 updated, this issue is gone. I can connect wireless via 802.1x/PEAP WiFi now.
Nov 9, 2012
#26 alal...@gmail.com
@cgatno,

I'm running 4.1.2 AOSP on a Galaxy S3. It's not official but the wifi drivers in the kernel are from a jellybean samsung source and all the binaries (including wpa_supplicant) are compiled from the 4.1.2 git tree.

As for the connection/disconnection interval. It seems to be happening randomly: in the txt file I attached for example, the connection did stay on for about 5 minutes and then it got disconnected with the authentication failed message. 

I wish there was a way to timestamp each logcat line. It would make things clearer.
Nov 9, 2012
#27 alal...@gmail.com
One more thing, when I was using ICS and JB 4.1.1, I was having severe connection issues. It would seem like it connects the first time I attempt to connect and then refuses to connect until the next day or a reboot.

The fix to this was the one you guys introduced in 4.1.2. To disable the session ticket advertising in wpa_supplicant. I backported that to the ICS and 4.1.1 wpa_supplicant back then ( https://github.com/madmack/wpa_supplicant_8/commit/a30e148451c383ee3423b661b9d1ac3d7e758dca ), recompiled and voila. I was able to at least get a connection through but like this page says, the connection does sporadically drop still with status_code 17 and 1 in wpa_supplicant. I still think it's a handshake problem with EAP secured networks.
Jan 9, 2013
#28 er.anura...@gmail.com
Hi Guys,
I am having note 2 and recently upgraded to JB 4.1.2 and now i am unable to connect to wifi which was not the case when i had 4.1.1. I am getting "Authentication error occurred message even when credentials are right".
Jan 10, 2013
#29 fusio...@gmail.com
HTC EVO 4GLTE with the 4.1.1 version of the software update. Cannot connect to the corp network using PEAP/MSCHAPv2. 

Can't get any answers from Sprint/HTC if or when this will be fixed. Assume its the same issue plaguing others. 

Can a similar fix like that from Alan Jeon be done to a non-rooted phone (Corp IT will not support rooted phones)?

Jan 19, 2013
#30 fmc3...@gmail.com
Hi 
have very recently upgraded my Galaxy Note 2 to JB 4.1.2. I'm having exactly the same issue as #28. And of course, it worked fine before the update.  
Feb 2, 2013
#31 pn.tips...@gmail.com
I'm using Galaxy S3 and have just updated it to JB 4.1.2 too. Now I can't connect to wifi network :( just like #28 and #30 I don't know what to do now 
Feb 4, 2013
#32 PurdueBo...@gmail.com
Hello
I have the same issue.  I upgraded from ICS to JB (4.1.1) before the holidays and now my phone will not connect to the 802.1x WiFi network.  It works fine with most other WiFi networks.  The apparent lack of attention to fixing this is getting very frustrating.  What is being done to address this????
Feb 4, 2013
#33 cgatno
Not sure if I posted this before or not, but just so everyone knows, this problem is pretty much fixed in source in 4.2.1. So, hopefully your respective devices will be updated to that version of Android ASAP because it should definitely bring the fix. I just wanted to let you all know that it's fixed in AOSP so you just need to convince your manufacturers to update now.
Feb 4, 2013
#34 drmacinyasha
Issue is not resolved in 4.2.1. I am experiencing the same issue on 4.2.1 on a Samsung Galaxy Nexus (mysid) when connecting to 802.1X networks.
Feb 4, 2013
#35 cgatno
I have the same phone as you and am not experiencing the issue. When I said "pretty much fixed" I meant for the majority of networks that were not working before. Networks with certain kinds of encryption methods or certificates seem to still be broken, but most of the common network types work with the latest version of source. Have you tried build JOP40G yet? It's possible that a patch could be included in the new build.             
Feb 6, 2013
#36 luix...@gmail.com
Got the same issue.

Galaxy S3 with 4.1.1

Tried restarting the router, restarting the phone. Forgetting the network. and still no luck.


Feb 19, 2013
#37 nicolasb...@gmail.com
Sabe issue here.

Using a Motorola XT890, I was able to connect while using my Motorola Droid 2 with no problem at all. This time, I'm not even able to imput the wifi password.
Feb 19, 2013
#38 nicolasb...@gmail.com
I was able to conect while using the WiFi Manager app avaiable at the Google Play

https://play.google.com/store/apps/details?id=org.kman.WifiManager&feature=search_result#?t=W251bGwsMSwxLDEsIm9yZy5rbWFuLldpZmlNYW5hZ2VyIl0.

If anyone want to use the apk.
Feb 19, 2013
#39 nicolasb...@gmail.com
I was able to conect while using the WiFi Manager app avaiable at the Google Play

https://play.google.com/store/apps/details?id=org.kman.WifiManager&feature=search_result#?t=W251bGwsMSwxLDEsIm9yZy5rbWFuLldpZmlNYW5hZ2VyIl0.

If anyone want to use the apk.
Mar 12, 2013
#40 chops1...@gmail.com
Can anyone test the Jelly Bean release that just came out for the Droid Razr on this issue?  I really want to upgrade but won't if I can't connect to my work wifi.
Mar 20, 2013
#41 skwerlre...@gmail.com
Same issue here with the Droid Razr Maxx- no connecting to WiFi either. It saves the network, but does not connect.
Mar 22, 2013
#42 adrienne...@gmail.com
Having the same issue on a Droid Razr and found a list of routers that are not supported on another blog. May be helpful to those in need

http://www.droidrzr.com/index.php/topic/13234-no-wi-fi-after-jelly-bean-update/
Mar 22, 2013
#44 skwerlre...@gmail.com
Comment 42 solved it for me. My router was the first one on the list. Thank you so much!
Mar 23, 2013
#45 arto.jar...@gmail.com
I believe the router Belkin F5D 7231-4 should be added to the list of "old unsupported routers". I'm using it as an extra access point in my home. There doesn't seem to be any firmware updates available for this router. It has stopped working both with my Galaxy 10.1 tab and my Galaxy II phone after the Android update. It works fine with all my laptops with varying operating systems. I can still connect to my other router, a newer D-Link, with both the tablet and the phone. -A
Apr 3, 2013
#46 syms.m...@gmail.com
Nexus 7 with 4.2.2. wpa_supplicant log from logcat has

04-03 13:07:36.160: E/wpa_supplicant(1836): android_priv_cmd: failed to issue private commands
04-03 13:07:54.739: I/wpa_supplicant(1836): wlan0: CTRL-EVENT-DISCONNECTED bssid=00:1b:90:57:3c:30 reason=23

and the device fails to connect to the work wpa2 enterpise (PEAP) secured network.
Jun 12, 2013
#47 thi...@gmail.com
I'm on a custom 4.2.2 and I couldn't connect to the PEAP network at work. 3G reception is terrible there and everyone else on their iPhones can connect just fine.

I don't understand why it is such a frustrating experience to use WiFi on Android. 

Can't connect to PEAP, can't connect to ad-hoc. I'm a consultant and the client I'm working for now only has cable network, if ad-hoc worked on Android I could just share it, but I can't. 

I almost can't believe android simply doesn't do this as I had no such problems on my iPhone.

Might not be a deal breaker for OP, but I can promise Google it is for most of people and proper attention should be given.
Jul 15, 2013
#48 Laze...@gmail.com
I agree with #47.  This issue + my phone (galaxy nexus) having a bluetooth 4.0 and not using bluetooth 4.0 has just been a frustrating experience at best, and an abysmal experience overall.  With those things combined this is what I get:

1. Not able to connect to work network
2. Not able to use my new bluetooth devices

RIDICULOUS!
Aug 26, 2013
#50 mehmetal...@gmail.com
I have a tablet running 4.1.1 and phone 4.1.2 . Both cannot connect to enterprise network with following configuration : 

WPA2 Enterprise
PEAP V0
MSCHAPv2
CA Certificate
Username/Pass from One Time Passcode Device .

Android 2.x devices and iOS devices connect just fine. 
Aug 31, 2013
#51 trul...@gmail.com
Is there a solution to this problem today?

I have the same problems.

TY
Sep 13, 2013
#52 vanv...@gmail.com
I've found a solution to my Razr I Android 4.0.4 just by installing the app "WiFi Manager" (https://play.google.com/store/apps/details?id=org.kman.WifiManager). 
The app showed the option PEAP and phase2 MSCHAPv2 automatically. In just 1 minute i've connected succesfully to my work WiFi.
Sep 13, 2013
#53 paul.l...@gmail.com
How can we get this prioritized?

Sep 19, 2013
#54 cgpelleg...@gmail.com
same issue here !
Oct 18, 2013
#55 jeongyeo...@gmail.com
Hello, 
my recent purchased note 3 has same problem as not able to connect PEAP/MSCHAPv2.Please prioritize to solve this issue. 
Oct 25, 2013
#56 lazyni...@gmail.com
Same issue on Galaxy Note.  This thread started August 2012.  No progress in 14 months?!?!?!  This is making my company reconsider the Android presence in our network.  Please PLEASE re prioritize and UPDATE!
Oct 28, 2013
#57 christa.mabee
The Motorola Android JB devices I was evaluating are useless on my client's campus due to this bug. Pretty embarrassing. 
Dec 2, 2013
#58 jm.ro...@gmail.com
I believe the CAUSE of the issue is that the problematic PEAP Wifi signals are using certificates that are not signed properly. When connecting from a laptop, I'm asked to make an exception for "untrusted" certs, but since android doesn't allow users to make exceptions, the connection just fails.
Dec 27, 2013
#59 mauro.pa...@gmail.com
Same problem here!

RAZR I does not connect using PEAP.
Jan 2, 2014
#61 brauckmi...@gmail.com
Same here...Galaxy Note 3 running the 4.3 MJ5 image.

The problem is most likely related to how Android handles it's root certs.  During EAP-PEAP handshake, the server (RADIUS SERVER) sends his certificate to the supplicant.  It is then up to the supplicant to validate that this is a trusted cert by using the root cert (and possibly intermediate certs) that issued the server certificate.  If this validation fails, then the auth will terminate right then and there.

HOWEVER, in my lab testing, I can see that my RADIUS server is, in fact, sending both the EAP-Success AND the RADIUS Access-Accept to the RADIUS CLIENT (Wireless router).

I'm going to test with my company's other RADIUS server (Steel-Belted RADIUS) to see if the issue lies with how the server interprets the end of the auth process.

.
Feb 11, 2014
#62 guardr...@gmail.com
Same here, Samsung Galaxy S Advance GT-I-9070 , JB- 4.1.2

Router DLINK - 860 (AC)

2.4 GHz and 5 GHz WLAN available, both worked just fine for half a year and suddenly 5GHz, WLAN stopped working. Open WLAN outside home was used and also Flight mode of the was used prior the problem. 

-> Router FW was upgraded to v. 1.0.5 and all the possible combinations of encryption and cipher was tested even WEP (WPA,WPA2) etc.

---> The result is that every time tried to connect to the network there is AUTHORIZATION ERROR. Looks like there is no cure to this what so ever? ...

What might cause this and what to do to fix my phone so that both networks (2.4 GHz and 5GHz) could be used again ?
May 21, 2014
#64 MikeyMik...@gmail.com
Hi all,

Network Engineer at Boston University here.  We have Cisco APs (2600,3500,1250,1142) on WiSM1s and WiSM2s, 802.1x, WPA/WPA2, AES, PEAP, MSCHAPv2, RADIUS queries AD.

I have users with Android devices running version 4.0.3 and 4.0.4 and I'm sure other versions which have issues with dropping their Wi-Fi connection.  The behavior that everyone else is seeing on their Android devices is exactly what we're seeing.  I also have users who are running newer devices with version 4.4.2 and they work beautifully.  

So, I know the issue was fixed in version 4.4.2 but my question is what version did they officially fix this in?  I keep seeing 4.2.2 but I want to know for sure so I can get a device and load that version on it and test it out.

Thanks in advance for any and all ideas.

Mike


Sign in to add a comment

Powered by Google Project Hosting