My favorites | Sign in
Project Home Issues
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 3293: ADB & samsung galaxy - not working
10 people starred this issue and may be notified of changes. Back to list
Status:  Released
Owner:  ----
Closed:  Aug 2009


Sign in to add a comment
 
Reported by alextheb...@gmail.com, Jul 17, 2009
Hi, sorry in advance for my poor english :P
I'm using a Mac and I have a Samsung Galaxy, I can't use adb to connect the phone to the 
computer, it doesn't find any device.
I found a lot of people having the same problem on other O.S. (linux and windows)
http://groups.google.com/group/android-
developers/browse_thread/thread/726ea864e89985ec/d8557941a2be9ec9?lnk=raot
http://www.androidiani.com/forum/samsung-i7500-modding/2742-adb-e-samsung-
galaxy.html
please help us!! 
Jul 17, 2009
#1 alextheb...@gmail.com
sorry, now everything is ok with sdk 1.5_r3
Jul 18, 2009
#2 jsource...@gmail.com
I have tested it on a Mac and it works with 1.5_r3. On Linux however, I does not seem
to work.

With the HTC android phones, it required the following line in
/etc/udev/rules.d/51-android.rules:

SUBSYSTEM=="usb", SYSFS{idVendor}=="0bb4", MODE="0666"

As the Samsung Galaxy has a different vendor ID (04e8) I changed that line
accordingly, but it is still not recognized.
Jul 19, 2009
#3 kenny@the-b.org
I don't know if this will help with your problem, but 1.5_r3 introduced a new command
called "android update adb"  Give that a try.
Jul 20, 2009
#4 rune....@gmail.com
Still not showing any devices (On Linux here) after "android update adb"
Jul 21, 2009
#5 danra...@gmail.com
1.5_r3 is supposed to support Galaxy. someone has posted a linux adb on the 
developer groups which is claimed to work well with Galaxy. 
For me on winxp, r3 plays nice.

Jul 24, 2009
#6 oruna...@gmail.com
The patched adb for linux can be found at http://floe.butterbrot.org/external/adb.gz
It is working for me (on gentoo linux), but would be nice to include the patch in a
new SDK release. See review discussion as well:
https://review.source.android.com/#change,10728
Aug 7, 2009
#7 x...@google.com
A fix for the issue with the Galaxy on linux will be in the next SDK release.
Status: FutureRelease
Sep 16, 2009
#8 xav%andr...@gtempaccount.com
(No comment was entered for this change.)
Status: Released
Dec 4, 2009
#9 yglodt
Hi, don't know about others, but since I upgraded (in fact newly installed) SDK 2.0.1
today, my Galaxy is not visible anymore again.

Replacing the adb with the one which I used with the 1.6 SDK made me productive again.
Jan 17, 2010
#10 martin.h...@gmail.com
I'm having the same problem, updated to 2.1 from 1.6 and now adb won't find my Galaxy. 
The linked patched adb above does not work.
I do not have the 1.6 adb so I cannot test that.
Feb 4, 2010
#11 sebastie...@gmail.com
Same problem here...2.1 SDK and adb can't find the Galaxy. Any solution ANYWHERE
about that???
Feb 10, 2010
#12 bcafa...@gmail.com
In the bump from 1.6 to 2.0 (where the usb_linux.c code got a bit of a rewrite), the 
fix described here for Samsung phones was lost/broken. There is a newer patch 
available in  bug #5027 :
https://code.google.com/p/android/issues/detail?id=5027

It worked for me with a Galaxy Spica
Sign in to add a comment

Powered by Google Project Hosting