My favorites | Sign in
Project Home Issues
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 19394: eMail Application does not allow configuration of outgoing smtp server with no authentication.
10 people starred this issue and may be notified of changes. Back to list
Status:  New
Owner:  ----


Sign in to add a comment
 
Reported by j...@joeld.com, Aug 19, 2011
Device: Asus Transformer
Version: Android Honeycomb 3.2

- Steps to reproduce the problem.
Configure a new email imap account on the builtin android 3.2 email application > manual setup > imap > incoming server settings > outgoing server settings.

Configure the outgoing server settings with an smtp server, security type None, port 25, Require sign-in should be unchecked.  After hitting next the email settings will be checked by connecting to the smtp server and an error is reported:

"Setup could not finish"
"authentication methods are not supported by server"

- What you think the correct behavior should be.
I know that my smtp server does not support authentication, the android email application should allow configuration of an smtp server which does not support authentication.

Thanks
Joel

Aug 19, 2011
#1 naiq...@people.net.au
I am having the same problem with a pop3 account, exactly the same error message.
I know all my inputs are correct as I checked them against my Outlook account on my laptop running Win7.
Still looking for a solution.

Brian
Aug 23, 2011
#2 ryangil...@hotmail.com
I am having the same problem. My internet provider aanet said that the issue is due to android versions 3.1 & 3.2.
Aug 24, 2011
#3 naiq...@people.net.au
I have updated to the latest build No. 8.6.5.9 - 20110816 hoping that might cure the problem, but no joy, I have installed K-9 mail for the time being. Set it up with the settings that the default does not like and it works OK, but would still prefer the default program as it is integrated into the home screen.
Brian
Aug 26, 2011
#4 naiq...@people.net.au
Problem solved, at the Outgoing server screen just change the Port to the correct port, then BEFORE you deselect Required sign-in, go down and delete the username and password that the wizard has inserted (I just backspaced them out) then uncheck Required sign-in. And all should work from there.
Totally NON intuitive, when you un-tick the check box it removes details from screen, but still keeps it behind the scene.
And for this we owe a big thank you to UINSIONN on Android Forums who found the solution.

Brian 

Aug 26, 2011
#5 j...@joeld.com
Thanks Brian for posting the workaround.  It worked great
Aug 26, 2011
#6 pwe...@gmail.com
Same same :-)
Still a bug but the workaround makes it usable.
Aug 27, 2011
#7 nehic...@gmail.com
I'm using Android 3.2 Honeycomb on the Asus Eee Transformer Pad and My POP3 setting for SMTP fails when trying to use SSL on port 465 with Sign in Required. I get the error msg 535Incorrect Authentication Data. The inbound Pop using SSL on port 995 works just fine with the same username & password Authentication data. Seems the SMTP function is broken badly from the above msg's plus mine... My Google Phone works just fine with the same settings. Hope a fix is quick in coming or this device will be quick in going... away.

Norm
Aug 27, 2011
#8 naiq...@people.net.au
Norm I did not thing SMTP needed any security settings, why don't you give the above solution a try for your SMTP settings.

Brian
Sep 22, 2011
#9 psinn...@gmail.com
Thanks #4. There is no way I would ever have worked that out.
Oct 4, 2011
#10 tom.d...@gmail.com
I can confirm this issue. On 3.1 I have not seen this issue on different vendor tablets.
The tablets with 3.2 do show this issue.

The fix, as posted by #4:

My server configuration doesn't support user verification and uses port 25

* Activate user verification
* Delete username & password field information
* Deactivate user verification
* Continue
Jul 8, 2012
#11 akkalan...@gmail.com
Comment #4 is the best solution. Thanks
 
Sep 30, 2012
#12 Rahim.Ti...@gmail.com
Omg THANK YOU BRIAN !!!! life saver !
Dec 6, 2012
#13 shyam.ra...@gmail.com
Thanks Brian for suggesting a solution.  It worked great

Dec 12, 2012
#14 james.th...@gmail.com
None of the above worked for me. The only that that occasionally works is a restart of the device. I still suspect my carrier, Vodafone UK...
Dec 22, 2012
#15 andrew.k...@gmail.com
I just solved this for myself.  What I did is I went into "Account Settings" on the cellphone, and when I got to the outgoing server settings, I unchecked "login required" and now there is no problem.  

What I think happens is that you are already signed into the account through the POP server, and then the cell phone gets confused and thinks that the site won't let you log in, while in reality you are already logged in.  Anyway, it worked for me, and now if stops saying "Server does not support authentication" and immediately sends all my email.  Good louck everybody.
Dec 22, 2012
#16 andrew.k...@gmail.com
Oh, I see that my solution is the same as comment #4.  Hat tip to you, sorry.  I discovered it on my own.

May 27, 2013
#17 66barn...@gmail.com
Brilliant!  Thanks Brian.  :-)

May 2, 2014
#18 rjc862...@gmail.com
confirmed still present in 4.4 kitkat come on /devs/ wake up the work around in post 4 works but it should't be fracking necessary 
Sign in to add a comment

Powered by Google Project Hosting