My favorites | Sign in
Project Home Issues
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 16955: 3.1 Web fonts broken in stock browser
7 people starred this issue and may be notified of changes. Back to list
Status:  Obsolete
Owner:  ----
Closed:  Jun 2013


Sign in to add a comment
 
Reported by plane...@gmail.com, May 18, 2011
Motorola Xoom (WiFi)
Honeycomb 3.1 (stock)

After updating to 3.1 web fonts no longer load through CSS/Font-face. Previous to the update the following worked fine in Honeycomb:

@font-face {
	font-family: 'Pictos';
	src: url('pictos-web.eot');
	src: url('pictos-web.woff') format('woff'), url('pictos-web.ttf') format('truetype'), url('pictos-web.svg#webfontIyfZbseF') format('svg');
	font-weight: normal;
	font-style: normal;
}

Now the "Pictos" fonts will not load; the default fall-back font is shown instead.

This issue does not occur on either an Android phone running 2.2 or Honeycomb 3.0.1, it is unique to 3.1.

May 25, 2011
Project Member #1 jr...@android.com
Do you have a sample page or full example of the problem? We cannot reproduce, and the examples at http://pictos.drewwilson.com/ work fine in 3.1
Status: NeedsInfo
Owner: jr...@android.com
May 26, 2011
#2 geoff.to...@gmail.com
I think the Pictos site is displaying images, not the actual fonts, as he sells both fonts and pngs.

Here's a page with the demo Pictos html - 

http://stage.attend.manexa.com/mobile/fonttest/PictosRegular-demo.html

Viewed in a desktop browser or Android 2.2, etc and the symbols show. View it in 3.1 and it falls back to the default letter font. This worked in 3.0 but something changed - do web-fonts have to be implimented/called differently now, perhaps?

May 29, 2011
#3 plane...@gmail.com
Posted under the wrong account but that's me above. Thanks for looking at it! :)
Jun 27, 2011
#4 johnablo...@gmail.com
I am also seeing this issue with MathJax, a javascript library for math typesetting. 2.2 properly uses web fonts; 3.1 doesn't even download them.
Jun 28, 2011
#5 johnablo...@gmail.com
Check that. After more investigation, 3.1 does seem to properly use web fonts in many cases. The issue with MathJax seems to be that the @font-face directives are dynamically generated by javascript (or perhaps it's when/where they are generated). When the same @font-face statements are listed explicitly in a static style sheet, the fonts load and the page displays correctly. Under 2.2, the web fonts are used correctly even without the static @font-face declarations.

The issue in the page cited by #2 may be something different. According to

http://stackoverflow.com/questions/3200069/css-fonts-on-android

android chokes on the local smiley hack.
Jun 28, 2011
#6 ifung...@gmail.com
CSS/font-face doesn't work for me on 3.1 either. I have two sites that use Google web-fonts that were rendering correctly before 3.0 but then stopped working after the OTA update from ASUS.
Jul 13, 2011
#7 ge...@maximumgamer.com
@johnablo@gmail.com, can you post how you listed yours to get them to work?
Aug 11, 2011
#8 giles.se...@googlemail.com
Also getting same issue on Asus eee pad on 3.2, viewing own sites or http://www.google.com/webfonts. It just shows default font :-(
Aug 22, 2011
#9 mynameis...@gmail.com
I'm having this issue too. My sites don't load the custom fonts from Typekit. To me this is a major issue because the sites I've designed are displaying default Droid Sans (which I have no problem with) if I can make a separate style sheet for specifically 3.1 honeycomb as a workaround.
Feb 21, 2012
#10 s...@typekit.com
This problem appears to have started in Android 3.1. It's a problem with the Skia library that's used to load and draw fonts to the screen. I'm not sure if 3.1 is when Skia was introduced, or if there was a change in Skia with that release that introduced the issue.

The issue stems from this line in the Skia source code: https://code.google.com/p/skia/source/browse/trunk/src/ports/SkFontHost_android.cpp?r=3199#755 It requires that a font have a name while it's being loaded. Many font-face services that serve commercial fonts remove the name from the name table so that the font isn't installable within operating systems. Usually, browsers don't require that name table information to be present in order to use the font file with @font-face.

It appears that in the latest version of the Skia source code, this issue has been fixed. The fix landed in this change: https://code.google.com/p/skia/source/detail?spec=svn3202&r=3202

So, future versions of the Android default browser that incorporate that Skia change will work with these TTF files again. In the meantime, Typekit has started serving SVG files to Android's default browser from 3.1 to current, since SVG files work fine. More details here: http://blog.typekit.com/2012/02/21/update-to-typekits-android-support/
Jun 8, 2013
#11 jbq@android.com
(No comment was entered for this change.)
Status: Obsolete
Owner: ---
Sign in to add a comment

Powered by Google Project Hosting