My favorites | Sign in
Project Home Issues
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 14698: receiving multiple instances of the same text message
60 people starred this issue and may be notified of changes. Back to list
Status:  Duplicate
Merged:  issue 14503
Owner:  ----
Closed:  Jun 2013


Sign in to add a comment
 
Reported by comk4...@gmail.com, Feb 12, 2011
- Steps to reproduce the problem:don't know how to reproduce the error
- What happened: I received a text message from my contact. Upon reading it
I closed the messaging app and then received notification that the same text
Had been sent. When I asked my contact if he sent it again he said no only once.
This happens with various other contacts as well. Side note I restarted my phone right
After the ninth message arrive only to have another copy arrive right after the boot up. I'll
Include three alogcats
- What you think the correct behavior should be: I should only received one text
Message.

What deviceand what version of Android:
Motorola droid>2.2.1
If you happen to have a development environment, please also run "adb
bugreport" and archive the output as it could help diagnose the problem.

Jun 15, 2011
#2 chelsy.r...@gmail.com
Same problem here. Droid X > 2.3.3. Happened right after I updated with the Gingerbread release. Im getting the same text 5-6 times each!
Jun 15, 2011
#3 izkar...@gmail.com
I have this issue with AIM, FB, and Google Talk. I sitll have 2.2 for the Optimus V. I know exactly how this happens for me: it triggers when I let it sleep. If I'm in a conversation and the screen is on, everything is okay-- but if I let the screen turn off and I have to enter in the pattern to unlock the phone, things will go to heck, and I'll a seemingly endless torrent of repeat messages.
Jun 16, 2011
#4 stacey.c...@gmail.com
I also have a Droid X with 2.3.3 on it.  Sometimes I get the same message multiple times all at the same time, other times I'll get a message once and then receive it again a few minutes later (and this can happen multiple times).  I had a similar problem before with an original Droid (that I had reported on here), and resets only seemed to help temporarily and it pretty much went away on its own.  I just tried clearing my system cache so we'll see if that helps at all.  I really don't want to have to do a factory reset (especially knowing that won't really fix it).  The fact that it started after the update really makes me wonder.
Jun 28, 2011
#5 stacey.c...@gmail.com
Clearing system cache didn't help.  The problem got a lot worse, and it has actually sent/resent messages to people hours after it was originally sent.  I have also tried a factory reset, but that doesn't seem to have helped (may have made it a little less frequent so far but that's about it).
Jun 29, 2011
#6 doom...@gmail.com
Happening to me on stock 2.3.3 Droid X.  Multiple copies of the same text message from different people so that makes me think it has to deal with either my network (Verizon) or my phone.
Jun 30, 2011
#7 peteoha...@gmail.com
Same issue, droid x...
Jul 4, 2011
#8 rtul...@yahoo.com
Same problem with my new droid x2
Jul 12, 2011
#9 adam.sha...@gmail.com
Same issue. different numbers, carriers and operating systems. Please fix
Jul 19, 2011
#10 stacey.c...@gmail.com
Still a problem. From other comments, obviously not linked to a network. Please fix!
Jul 24, 2011
#11 wedavis.ku@gmail.com
Same issue but apparently I am sending out multiples as well. 
Aug 13, 2011
#12 geey...@gmail.com
Same issue Droid X.  Version 2.3.3. 
Aug 14, 2011
#13 stacey.c...@gmail.com
I enjoy how nobody from Google has responded to this.  My phone was acting somewhat better for a while, but now it has started doing this a lot again.  It's getting really annoying, and I wish someone would do something about it, as it's obviously a widespread issue and not just related to one phone or one carrier.
Sep 9, 2011
#14 rob.fr...@gmail.com
I running 2.3.3 on an LG G2x.  Nice phone but it suffers from the same issue.

I've seen it in earlier versions of Android 2.x so it's not specific to this version.  I don't believe it to be a network issue as people on multiple carriers have reported the same behavior.

I looked at my messages through some code I put together to get the attributes of each message and print them out.  I sent a text message from Google Voice to my phone and the thing showed up 8 times.

Unfortunately the only thing that is similar to all of the SMSes is the body and address.  The date and ids are different so they must be assigned once they hit content://sms/inbox.

This exists somewhere in the messaging code in the platform - this is not a network thing.  Google needs to either fix it or someone else needs to come up with some kind of workaround app to basically not notify the user when the same text shows up in their inbox.  There is enough information on an SMS to get an idea of what's a duplicate and what isn't - it may not be 100% correct but it would be better than not doing anything at all.
Sep 28, 2011
#16 jak7...@gmail.com
Me too. Droid X Android 2.3.3

Help!?
Sep 28, 2011
#17 petalsan...@gmail.com
This is RIDICULOUS.. Droid X 2.3.3

Happens in regular text app AND on handsent...

LAST NIGHT. I RECEIVED 17 OF THE SAME TEXT -...

Tweets are also coming over multiple times. Never more than 4 in a row... 

This MUST be fixed.. MUST - I would go to iphone if this continues..

Total bullshit.
Oct 17, 2011
#18 stacey.c...@gmail.com
While speaking to someone at Verizon, I brought this issue up, and she said that it's most likely a network/carrier issue, though not limited to a single one.  She said she's had the same thing happen with iPhones (so it's not just limited to Android).  Even if that's the case, I'm sure everyone would appreciate it if someone from Google would respond to at least say that.  Although I still doubt that's the main issue.
Nov 7, 2011
#19 andites...@gmail.com
Hi i'm using the following code to send message but getting 2 sms on the other device..I'm Using Android OS 2.0 and Motorola device.

public void sendMultipartSMS(String phoneNumber, String message) {

			try {
					 
					 String SENT = "SMS_SENT";	
//					 String DELIVERED = "SMS_DELIVERED";
				     SmsManager sms = android.telephony.SmsManager.getDefault();
				     ArrayList<String> parts = sms.divideMessage(message);
				     int messageCount = parts.size();
				    // ArrayList<PendingIntent> deliveryIntents = new ArrayList<PendingIntent>(messageCount);
				     ArrayList<PendingIntent> sendIntents = new ArrayList<PendingIntent>(messageCount);
				     for (int i = 0; i < sendIntents.size(); i++)
				     {
				         Intent sendInt = new Intent(SENT);
				         PendingIntent sendResult = PendingIntent.getBroadcast(baseContext, 0, sendInt, 0);
				         sendIntents.add(sendResult);
				     }
				     if (phoneNumber.length()>0 && message.length()>0)  
				     {
				    	 sms.sendMultipartTextMessage(phoneNumber, null, parts, sendIntents, null);
				    	 
				     }
		       
		    }catch (Exception e) {
				e.printStackTrace();
			} 
Nov 26, 2011
#20 mrjvazq...@gmail.com
Same issue, but my situation seems to be related to an SMS message that seems to be caught in Android limbo.  What I mean by this is that this particular text message will show up as a notification, but is not to be found anywhere in  the SMS inbox.  Immediately after this problem started happening, I started to receive multiple notifications - and in fact, multiple copies - of the exact same text message.  Tried resetting the phone, still same problem.  I am guessing there must be a file somewhere that is corrupt and causing this problem, but where to start looking?
Dec 9, 2011
#21 brandon....@gmail.com
My wife's HTC Sensation 4G on T-Mobile (2.3.4) started doing this after updating to software 1.50.531.1 yesterday (12/8/2011). I have an identical HTC Sensation 4G and my phone is not doing this. As stated above, I suspect that it is a corrupt file. Thoughts?
Jul 5, 2012
#22 rbig...@gmail.com
I get the same thing on my AT&T HTC One X with 4.0.3. It happens in both the HTC Sense Messages app and GO SMS Pro, so I think it's an Android bug.
Sep 29, 2012
#23 orange...@gmail.com
Same problem,cant believe it's not fixable....htc desire andr.2.2. Switched off the phone be4 getting on the plane,after switching on all messages were deleted...no backup..messages 2 years old. Trusted htc brand but not anymore.very angry & disappointed!! 
Jan 1, 2013
#24 dave.bro...@gmail.com
Same issue with a new Xtreamer Aiki on Android 4.0.3 ...
Jan 13, 2013
#25 sa154...@gmail.com
I was having this issue of multiple receipts of the same SMS message on a Samsung Captivate Glide.  I upgraded phones to Google Nexus 4, however the problem remains.
Jan 14, 2013
#26 comk4...@gmail.com
I can't believe this three years later and only twenty five people had this issue?
no wonder this issue isn't getting more response....
Jan 15, 2013
#27 montytri...@gmail.com
What's the solution?  I have this same problem on my galaxy nexus.
Jan 24, 2013
#28 ajshan...@gmail.com
Same problem on Galaxy Nexus. Incredibly frustrating and a huge battery drain.
Jan 26, 2013
#29 dave.bro...@gmail.com
Ok I maked a fresh install of my Stocked rom on my phone, and get no more the problem ...

Hope it will helps you
Jan 28, 2013
#30 woodiana...@gmail.com
AT&T. Samsung Galaxy Nexus. 4.2.1. Not rooted. Fully stock. No 3rd party messaging apps. Inconsistent. Most of the time I get the normal 1 message but sometimes I get 3 or 4 or more of the same one usually spaced a minute or two apart. I have noticed it happening more often when the phone is under load (e.g. when just completing a boot sequence). Could be the SMSC is timing out the dialog and failing the delivery attempt before it gets the ACK from the phone. 
Feb 12, 2013
#31 steffl...@gmail.com
I have the same issue, it started out with a text here and there showing up 2x... now it is virtually ALL text showing up at least 2x, and over the past two weeks a lot show up more than 2x with the worst case being last night I get one message, two parts, 5x. So the one text message looks like ten when it should look like 2.

OMG PLEASE HELP!!!!

DROIDX V2.3.4 (system 4.5.621.MB810.Verizon.en.us)
Feb 13, 2013
#32 st.jur...@gmail.com
I am experiencing the same problem. It's extremely annoying.
Very same problem as woodiana above - Stock Galaxy Nexus, Android 4.2.1., not rooted. Using only stock messaging app. This is my problem: "Most of the time I get the normal 1 message but sometimes I get 3 or 4 or more of the same one usually spaced a minute or two apart." I am experiencing this only with contacts with 1000+ messages in history. Please help, it's driving me crazy!
Feb 16, 2013
#33 TJEvan...@gmail.com
My wife and I both have this duplicate message issue.  We both have Kyocera Rise phones both on Virgin Mobile (Sprint towers used) both on Android 4.0.3  When she texts me, I get 2 copies of her message, when I text her, she gets 2 copies of mine.  Both of us only send the message once from our respective phones.

We're both using GO SMS as our text client, but the duplicates also appear on the stock messaging app as well.  I've uninstalled GO SMS, but the duplicates still appear on Stock app.
Feb 20, 2013
#34 alongd...@gmail.com
I'm having the same issue. Stock Galaxy Nexus, before and after the 4.2.2 update, I'm getting sometimes up to 6 duplicates of 1 text.
Feb 22, 2013
#35 bill.n...@gmail.com
Stock LG G2x, Android 2.3.3. Sometimes I get multiples of messages -- anywhere from 2 to 8-10+. I'm regularly in areas with low data coverage, but always have a strong cell signal. Incoming messages are from multiple contacts through multiple other carriers.
Feb 24, 2013
#36 babuol...@gmail.com
Stock Motorola Razr Maxx running Android 4.0.4. I get 2-10 duplicates. Have been unable to pinpoint a common thread with sender's phone type or network. 
Mar 5, 2013
#37 francis....@gmail.com
Stock Samsung Galaxy Nexus i9250.  Version 4.2.2.  Same issue for the last 3-4 months, few months after the purchase of the phone from the Google store.  Last duplicate happened 20 minutes ago; SAME message, EIGHT times.  

Has to be a phone/android issue. I've had all iPhones ( iPhone 3G - iPhone 4s ), same plan, same service, same locations and I've NEVER encountered this problem before.  

So annoying and needs to be fixed!
Mar 6, 2013
#38 DLS...@gmail.com
T-mobile Galaxy Nexus non rooted. 4.2.2 Currently running Handcent(third party app) but from what I've been reading it doesn't matter much. I'm about to delete handcent and hope for the best. This has been a problem for months!
Mar 7, 2013
#39 11roy...@gmail.com
Hi I am using Sony W8 which I recently updated to Android 2.3.7 GingerXperia  . I have started receiving a single message multiple times from my contacts and this is very annoying. Is there a permanent fix that I can apply to have this fixed?
Mar 11, 2013
#40 rusch...@gmail.com
My wife and I both have stock Nexus 4's.  Both frequently receive multiple text messages (up to 8 times).  Issue before and after 4.2.2 update.
Mar 18, 2013
#41 kuo.zi.c...@gmail.com
Galaxy nexus maguro rooted and custom ROM with the latest radio installed and I get this issue as well... It is very annoying because in the stock messaging ROM there's no way you can delete more than never message in the same thread bar deleting everything... Seeing that everyone is stock and not rooted I think the problem is with the radio/messaging app itself? 
Mar 25, 2013
#42 gobralessforfun
Started happening yesterday. I have a Galaxy Nexus (stock 4.2.2).
Anytime a receive a text message from a contact, I will receive multiple copies of it (to the tune of 30+ before it eventually stops. This could go on for 5 or more hours, and the duplicate messages come a strange intervals, sometimes every 2 mins, sometimes 10 mins apart, sometimes more. It is driving me crazy. Plus, it causes my phone to heat up, and drains the battery in no time flat! After receiving duplicate texts from just one contact for the better part of an hour, my phone died.
Under an hour and it went from completely full to completley dead because of this issue!
I'm trying clearing all my text threads, see if that will (somehow) fix it? Next step I will try clearing all the data and cache from the Messinger app. My next step (unfortunatley) is going to be doing a factory reboot. Not happy if it comes to that.
Apr 26, 2013
#43 MKBrown...@gmail.com
Same issue. My Galaxy Note 2 is only about a month old.  My carrier is Sprint, but messagrsc from people on AT&T, Verizon and Sprint are being duplicated many times over many hours.  If this is going to be a permanent  problem,  I will reluctantly go back to an iPhone
Apr 28, 2013
#44 brandon....@gmail.com
Make sure to enable your network date and time to use the network.  I enabled and mine and the issue has not happened since.
May 1, 2013
#45 alevenso...@gmail.com
always been on auto date and time
May 1, 2013
#46 alevenso...@gmail.com
google is ignoring the issue
May 1, 2013
#47 vikram.g...@gmail.com
I am having the same issue on my new SGS4. I did not seem to have this issue in any of my old ones, SGS2,SGS3, SGG Duos.
May 7, 2013
#48 Nino.H.F...@gmail.com
Same thing on Verizon Galaxy Nexus. Seems to happen with some contacts and not with others.
May 8, 2013
#49 comk4...@gmail.com
I think that someone should try going to the applications menu then find google framework and stop the application and delete all the files and clear the cache please note that you may lose messages.  See if that helps. I have not had this issue with my Galaxy Nexus but I remember how annoying it can be! Thank you to the user who stated that iPhone has the same issue.
May 9, 2013
#50 jodathej...@gmail.com
I receive duplicate text messages quite often, but usually only two at a time. Naturally the issue occurs from those I text most often - most of them are on different networks. It's not a huge problem so I normally just ignore it. Recently however my girlfriend (same phone different carrier) has been receiving the same texts every hour or so. Three of them in sequence. This recent (and hopefully temporary) problem seems more like a carrier issue, but since I've seen the duplicates since I got this phone I finally decided to do some research on the problem and ended up here. 

Basic info:

Phone: Samsung Galaxy GS3 SGH-I747
Carrier: AT&T
OS: Latest unmodified stock 4.1.1
Message App: GoSMS 4/26/13 update - stock messaging app is disabled in every way possible, no other  SMS apps installed. 
May 9, 2013
#51 sans...@sansnil.net
My sense is this issue is caused by the originating texting device. I see it happen when someone texts me where they have poor cellular reception. The device keeps thinking the text wasn't sent successfully and resends it.

BTW, has anyone validated that the multiple texts get billed, or if it's only one billed SMS?

May 12, 2013
#52 bradb...@gmail.com
I have the same issue. I get literally hundreds of duplicate texts each week. Please, please provide troubleshooting steps. No third party SMS apps installed

May 15, 2013
#53 jun8...@gmail.com
I have the duplicate text message issue on my GSM GNEX 4.2.2. I noticed that it almost always happens when I receive an SMS from an iphone.
 
May 20, 2013
#54 daniel.b...@gmail.com
I have a Motorola Razr Maxx.
I have been fighting with my network since February 2013 regarding text messages being received multiple times.  They are yet to find a problem.  Therefore I now believe it's the phone.
I have tried a factory reset, but it didn't help. I've flashed other firmware (all stock) and the problem went away for a few days, but came back.
The problem is random but seems to get progressively worse.  I will receive a message and then usually 5 minutes later it will receive it again for easily up to 3+ hours, but the interval is not constant, but mostly 5 minutes apart.  It can even stop and then start up again with the same message, sometimes the next morning.
I can receive one message 15 times, 25 times, 50 times, even had it more than 100 times.  It is never the same.
Now imagine 2 or 3 different texts have been received....all repeating over and over - you get very close to wanting to throw the phone against a wall.

Please someone take a look at this.
May 24, 2013
#55 Pathirag...@gmail.com
Try this solution: The first thing to check is the date and time settings on your phone. On your S2 or any mobile, go into settings, then date & time, and make sure you have your phone selected in the right time zone you are in. 

Manually set the time, then click the Automatic (Use network provided values) and restart the phone. :) Hope this helps :) 
May 28, 2013
#56 djamant...@gmail.com
Hi,

Did anyone try the time suggestion above? Did it solve the issue? 
May 28, 2013
#57 xmarkope...@gmail.com
Yes, i tried it and it did not worked :/ right now i got 3x the same message...
May 30, 2013
#58 Pathirag...@gmail.com
Has Google taken any steps to resolve this,this is soo annoying !!! 
Jun 8, 2013
#59 adame...@gmail.com
The same here - after rooting my phone some SMS messages keep annoying me up to 12 times. It does not happen with SMS notifications from Google calender. I am on O2 czech republic.

And yes, it definitely is a phone issue - when I put the same SIM card into an old Nokia, it works just fine.

Another issue here (might be found looking up the previous text, it's just copy & paste) someone stated the problem originates in the system - after receiving an SMS, it should send some data to the provider, like "ok, message received". If it does not, the provider keeps delivering the same text as if it got stuck somewhere.

Please Google braniac guys, help us out :).
Jun 8, 2013
#60 jbq@android.com
(No comment was entered for this change.)
Labels: Component-Networking Version-4.2
Jun 8, 2013
#61 jbq@android.com
(No comment was entered for this change.)
Status: Duplicate
Mergedinto: 14503
Jul 2, 2013
#62 bart.reu...@statik.be
I am on Mobile Vikings, a Belgian provider. They have an API, where I can check what actually came in or goes out, and what they charge me for. If I get a text, it shows me how many times I received that text. As they pointed out, in my history log, it only shows my texts once, so they only push the text once to my phone. Still my phone (a Google/Samsung Galaxy Nexus, so with an untampered OS) shows me that text multiple times.

-> Provider delivers only once, but Android gives me multiple notifications
Jul 2, 2013
#63 comk4...@gmail.com
Thanks @bart I have long suspected that the issue is with the Android server!  I'm going to try and find someone else who can help with this.
Jul 5, 2013
#64 vannac...@gmail.com
My whole family have Kyocera Rise through Virgin Mobile.  First my son's phone started receiving multiples of the same text, then my husband's, and now mine.  Strangely enough my daughter is not having this problem.  I have received the same text message, at last count 73 times.  Thank God, I am not charged per text.  I have no idea how to stop this but I did think, after reading previous comments, that if I could delete the last update, that may fix the problem.  Does anyone have any thoughts on this?  Is it actually possible to delete an update?
Jul 8, 2013
#68 BarryThi...@gmail.com
It's been happening on my G2x (P-999) for weeks, with no consistent trigger. It happens when I'm on the phone, and when it's sleeping. Not all messages, just some, and I can receive a few or a dozen repeats of the same message. I'm on a G2x, using the standard messaging app, Android 2.3.3, t-Mobile.
Jul 27, 2013
#69 brandv...@gmail.com
Same problem as others. I have no idea what the deal is, but it does not seem to want to stop sending the same text over and over again.
Sep 18, 2013
#70 pthea...@gmail.com
I get two messages, and only two messages every time. This seems to happen with 3rd party sms apps. I use hamdcent. (I see mixed reports with goSMS) but I also see mixed reports on numbers.

I have Kyocera torque (4.1.2 it also happened with stock firmware 4.0.[?]) 

I uninstall handcent, and new duplicates stop. Existing duplicates still appear in the database. I.e. in the stock app too.

I had handcent with htc evo with no problems. (Not sure what version of android it used.... I thought it may have been an issue with 4 but people repprt it with 2.2 & 2.3 and more than  two are appearing in 4.x so google didn't fix some error throttling it to a single duplicate unless Kyocera added a partial fix/check
Oct 11, 2013
#71 anandamb...@gmail.com
Same problem with me using HTC One not rooted.  I keep on receiving the same text again   and again.  I was using gosms, removed it installed handcent the same problem, used ninjasms still the same and now on slide sms but the same problem.  I called up my carrier in India and they say its a handset issue and cannot help.  I'm on android 4.2.2, sense 5.  Please can anyone provide me a solution for this.  Its very irritating. Thanks in advance..
Nov 13, 2013
#72 jjk...@gmail.com
It's been happening to me too, for several months.  Phone is an AT&T Samsung Infuse.  Very aggravating.
Dec 9, 2013
#73 tmcgow...@gmail.com
I have a Samsung Galaxy Note 3 on AT&T.  Both the integrated SMS messaging and Hangouts receive duplicate messages of ALL texts.
Feb 10, 2014
#74 prashant...@gmail.com
I have the same issue. I send and receive multiple copies. I have had my contacts tell me that my phone is behaving erratically by sending them multiple copies. Sometimes the copies are spaced apart over the course of hours.

Is there a service ticket for this issue at Google?
Feb 10, 2014
#75 metalar...@gmail.com
I've commented in a merged issue before: Nexus, with Mobile Vikings, in Belgium. I can see what messages my provider sent to me in their backend, and every message I receive only shows up once. I have had problems in the past, but the last weeks they seemed to be gone. Since two days I have troubles again, but I didn't add new applications on my phone recently, nor did I change anything.
It seems like when I send a message, my phone keeps sending it, and keeps the message marked as sending. I don't receive an arrived-report, and my contacts start telling that the message came through, multiple times. Also, my phone keeps receiving the same message over and over again.

Could it be that I have too many messages? Or that my phone is too heavy loaded, to actually keep the waiting in memory, and thus keeps sending the message again and again, because it is forgetting the process?

Is there anything we can do, instead of seeing messages from people reporting "me too" every time again? I would gladly help with anything that could solve this problem, as this is one of the first things every phone should be doing in a good way: making calls and sending texts.
Mar 10, 2014
#76 ch.sha...@gmail.com
same issue with LG Optimus 4GLTE F160S from the time when i have updated google hangout. 
Jun 28, 2014
#77 omonijof...@gmail.com
Same here... Reboot done.Wiped history. Acts randomly
Jul 17, 2014
#78 brooks.b...@conwaycorp.net
Same here.  HTC One,  Hardware version 0004, Software version 5.03.651.3
Sign in to add a comment

Powered by Google Project Hosting