My favorites | Sign in
Project Home Issues
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 12094: SMS Text Messaging - Wrong recipient recieving text messages.
20 people starred this issue and may be notified of changes. Back to list
Status:  Duplicate
Merged:  issue 9392
Owner:  ----
Closed:  Jan 2011


Sign in to add a comment
 
Reported by cdigiova...@gmail.com, Oct 23, 2010
I am using the Motorola Droid with Android 2.2 (Froyo).
  I have encountered a problem many times since installing Android 2.2 regarding SMS text messaging. The problem is described as follows.
     My SMS text messages are being sent to the wrong recipients. If I have multiple text threads in my messaging screen which I have not deleted yet, this is when i experience the problem. I also experience the problem if there are calls in my call log. For example; if I have 2 text threads on my messaging screen, I will click on Jon but when the thread opens up it will actually show Harry at the top. If I am not paying close attention I will end up sending the text to the wrong person. Numerous times I have made sure to click on the name 'Jon' and still the other text thread labeled 'Harry' opens up. The only time that I do not encounter this problem is when there are no other text threads on my messaging screen besides the one person that I am currently texting.
     A similar problem to the above, is as follows. If i have my friend Harry in my call log, and i open up my messaging screen to text my other friend Jon, the text will send to Jon on the screen but it actually sends to Harry whom is in my call log. For example I send Jon a text saying "How are you?". The text will show as sent to Jon on my screen, but I will get a reply from Harry saying "I'm doing fine, thankyou." The only way I have found to prevent this problem from occuring is to make sure that my call log is always deleted and empty.
     Both of the above problems are very serious to any Android user, and I have had the same complaints from at least 10 of my other co-workers who use Android 2.2 on the Mororola Droid. These other users also complain about their text messages being sent to people whom are inside of their call log instead of the person that it was intended to send to within their messaging thread. These users also have mentioned that they experience the problem in which when they clock on a persons name to text message them, a different thread will open up. I know through experience that I am not the only person experiencing this problem and that it is not my Motorola droid malfunctioning because myself, and my co-workers never had these problems with Android 2.1 . 
     The correct behavior should be as follows. When multiple text threads are on your messaging screen, the text thread that you click on should always open, instead of another thread opening up. As for the second problem, when a user has multiple calls within their call log, and the user texts one of their recipients, a person within the users call log should not recieve the text instead of the person that the text was sent to inside of the messaging thread.
     Best of luck to all of the men and women developing Android. I hope to see the above problems resolved soon, as they are potentially dangerous problems to all Android users.
Nov 17, 2010
#1 myarmiso...@gmail.com
Same issue on 3 month old HTD desire. Texts appear to send to the correct recipient, but in fact send to a competely random contact. The sent message displays the correct recipient, but they do not receive the message.
This is an issue of the  utmost priority, as it essentially makes the phone useless for texting, and therefore useless to me.
Nov 19, 2010
#2 josh.hu...@gmail.com
There are a lot of threads and posts about this issue although I haven't seen any posts with a solution.  It's been happening for months.  For me it appears that when I reply to an incoming text messaging my response intermittently goes to the last person I tried to reply to.  It makes the phone completely useless to me for text messaging and I wonder how the Android platform can continue to be so popular with a bug like this.  If my provider can't provide a solution I'll have to seek a phone with another operating system.
Jan 6, 2011
#3 robertpe...@gmail.com
I've experienced the following problem. I received a SMS from a person for which I had two mobile phones listed in the Contacts. The SMS came from the number marked as primary. I opened the message in Messages, wrote a reply and hit send. Guess what happened? The message was sent to that other mobile number. As it happened, this other phone was not used anymore, since it was a work phone, and this person already changed the job. I guess I send it to a former colleague, don't know, since I didn't get a reply. Luckily the message was only new years wishes:) Anyway, please fix this text messaging bug!

Handset: HTC Desire Z
Android Version: 2.2.1
Baseband version:  12.28e.60.140fu_26.04.02.17_M2
Kernel version: 2.6.32.21-g540967a htc-kernel@and18-2 #1
Build number: 1.72.405.2
Jan 6, 2011
#4 dange...@gmail.com
SMS from October 2010, originally sent to Contact A, was sent inadvertently by my phone without my knowledge to Contact X on 3 January 2011. Had a short text exchange with Contact X prior to delivery of Mystery October text. SMS thread consisted of: text sent to contact X, reply from contact X, I sent text to same contact, Mystery October text sent to contact X).

Mystery message did not show in my view of thread, only received/viewed by X. Contact X inquired in person, otherwise I would have not have known Mystery SMS was sent. This may have happened more than once, without my knowledge. Both are Android devices.

October message received by Contact X is not saved/archived on my SIM card or in my SMS Drafts. Approx 3 short SMS exchanges with X within a 2 week period, otherwise an infrequent contact.

Original Mystery SMS was a message sent to Contact A, my most frequent contact. Contact A deleted the received/intended Mystery message from her Android device in October.

Up to 10 threads, deleted daily. Apprx 6 locked SMS msgs. Locked messages do not include any instance of the recipient of the Mystery message, nor do they include the Mystery message. All drafts deleted daily. If a thread exceeds 20 messages per day, thread is deleted more often.

Call History also deleted every 1-2 days.
Internet history, cache, cookies cleared weekly.

HARDWARE:
HTC Espresso (MyTouch 3g Slide)
ANDROID OS: (Stock)
Android 2.1 - update 1
Kernel version: 2.6.29-ab809
htc-kernel@and18-2 #1
Build Number: 1.35.53.1 CL216830 Release-Keys
Software Number: 1.35.531.1
Browser Version: WebKit 3.1

APPS:
Messaging, Email, Browser: All stock android. Have not used alternate market apps for any of these services.
All social media apps installed as bloatware on my device are not active, have not logged in, and have never been used. Includes Facebook for MyTouch, Flickr, & Twitter.
Jan 20, 2011
#5 graffiti...@gmail.com
Exact same issue, i am seriously thinking of going back to blackberry. this is a worthless HTC G2 phone!!!!!!!!
Jan 29, 2011
#6 cgi...@google.com
Thanks for reporting this issue.  It was fixed as part of the solution to  bug 9392 .

https://code.google.com/p/android/issues/detail?id=9392#c1460
Status: Duplicate
Mergedinto: 9392
Oct 12, 2011
#7 elde2...@gmail.com
How can this be fixed when on a daily basis on my Thunderbolt, I send to at least 2 to 3 wrong recipients.
Dec 19, 2011
#8 DIGIton...@gmail.com
I think the bug still exists. I sent a message to one person, and he never responded.  Another person responded wondering what was going on. This is pretty scary... hope I'm not in hot water the past several weeks!
Feb 9, 2012
#9 nww...@googlemail.com
Same here.  Running Android 4.0 on Galaxy Nexus, using the green "Messages" speech bubble on the home screen.

I have two SMS 'threads' The second one was started by my SMSing "Richard".  When Rich replied to my initial text with a question (therefore it went to the right person initially), I went into the thread to add my reply, but the person named both on the threads list and at the top of the thread is "Martin", a totally different recipient.  I'm not sure about other people's issues, but martin has not received my responses in this thread, so may just be a name issue.

Feb 9, 2012
#10 nww...@googlemail.com
As a followup to Comment 9, I've just received a text message from "Martin", which has shown up in a brand newly created thread called "Richard".  So the thread names are thoroughly broke :-)

Sign in to add a comment

Powered by Google Project Hosting